summaryrefslogtreecommitdiffstats
path: root/system/tabbed/tabbed.SlackBuild
diff options
context:
space:
mode:
author B. Watson2014-08-27 00:12:58 +0200
committer Willy Sudiarto Raharjo2014-08-30 09:22:22 +0200
commita23409a7c22b45397ddf647bb373991e07395f03 (patch)
treed675254c7ab626aae4cb57bf8c903ef1c5ccc644 /system/tabbed/tabbed.SlackBuild
parentdb5cbf8c39d82816e8ba217d67046dd1f0d36866 (diff)
downloadslackbuilds-a23409a7c22b45397ddf647bb373991e07395f03.tar.gz
system/tabbed: Updated for version 0.6.
Support applying user patches Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system/tabbed/tabbed.SlackBuild')
-rw-r--r--system/tabbed/tabbed.SlackBuild34
1 files changed, 31 insertions, 3 deletions
diff --git a/system/tabbed/tabbed.SlackBuild b/system/tabbed/tabbed.SlackBuild
index a4d6773ca1..535a1d1e50 100644
--- a/system/tabbed/tabbed.SlackBuild
+++ b/system/tabbed/tabbed.SlackBuild
@@ -6,8 +6,14 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20140826 bkw:
+# - updated for 0.6
+# - add support for patches/. The old 0.4 build had this, but this one
+# works with simple config patches or the ones from suckless.org
+# - mention dmenu in the README
+
PRGNAM=tabbed
-VERSION=${VERSION:-0.5}
+VERSION=${VERSION:-0.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -52,6 +58,26 @@ find -L . \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+
+# Apply any patches the user might have added. This is more complex
+# than usual because we want to detect whether each patch needs -p0
+# or -p1.
+for i in $( ls $CWD/patches ); do
+ p=""
+ diff=$CWD/patches/$i
+
+ # best way to test a patch is use the patch command
+ patch -stp0 --dry-run < $diff 2>/dev/null 1>&2 && p=0
+ patch -stp1 --dry-run < $diff 2>/dev/null 1>&2 && p=1
+
+ if [ -z "$p" ]; then
+ echo "*** User patch $i won't apply with either -p0 or -p1, giving up" 1>&2
+ exit 1
+ fi
+
+ echo "Applying user patch $i with -p$p option"
+ patch -p$p < $diff
+done
sed -i \
-e 's,share/man,man,' \
@@ -60,8 +86,10 @@ sed -i \
-e "s,-O0,$SLKCFLAGS," \
config.mk
-sed -i -e "s,800,${WIDTH:-800}," $PRGNAM.c
-sed -i -e "s,600,${HEIGHT:-600}," $PRGNAM.c
+sed -i \
+ -e "/ww *= *800/s,800,${WIDTH:-800}," \
+ -e "/wh *= *600/s,600,${HEIGHT:-600}," \
+ $PRGNAM.c
make
strip $PRGNAM