summaryrefslogtreecommitdiffstats
path: root/system/slpkg/slpkg.SlackBuild
diff options
context:
space:
mode:
author Dimitris Zlatanidis2015-05-30 03:12:32 +0200
committer Dimitris Zlatanidis2015-05-30 03:12:32 +0200
commit2e9a41330c952c421bcc503d859896d3c8b00b74 (patch)
treed46224fdbee490d58a5f82df94e8581eca50e3f6 /system/slpkg/slpkg.SlackBuild
parentcaa2badcbcb5cceedef54e63e117310f72250d70 (diff)
downloadslackbuilds-2e9a41330c952c421bcc503d859896d3c8b00b74.tar.gz
system/slpkg: Updated for version 2.3.6.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'system/slpkg/slpkg.SlackBuild')
-rw-r--r--system/slpkg/slpkg.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/system/slpkg/slpkg.SlackBuild b/system/slpkg/slpkg.SlackBuild
index 8bb1635845..4042228554 100644
--- a/system/slpkg/slpkg.SlackBuild
+++ b/system/slpkg/slpkg.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=slpkg
-VERSION=${VERSION:-2.3.3}
+VERSION=${VERSION:-2.3.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,7 +60,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# avoid install man page and blacklist over setup.py
+# avoid install configuration files and man page over setup.py
sed -i 's/if "install"/if ""/' setup.py
python setup.py install --root=$PKG
@@ -78,7 +78,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/etc/slpkg
-# install configurations files
+# install configuration files
CONFIGS="slpkg.conf blacklist slackware-mirrors custom-repositories \
slackware-changelogs-mirror"
for file in $CONFIGS; do