summaryrefslogtreecommitdiffstats
path: root/system/sbsigntools
diff options
context:
space:
mode:
author B. Watson2023-12-11 23:47:16 +0100
committer Willy Sudiarto Raharjo2023-12-16 02:56:09 +0100
commit09d272245c4bea58cc892bcef54291a31b0892fe (patch)
tree4704ad7e36af2b6b318f05501a2f8c7546a6852a /system/sbsigntools
parenta4c8c785998c358a89c5cc96bec5ffe03934a00c (diff)
downloadslackbuilds-09d272245c4bea58cc892bcef54291a31b0892fe.tar.gz
system/sbsigntools: Updated for version 0.9.5, new maintainer.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/sbsigntools')
-rw-r--r--system/sbsigntools/README5
-rw-r--r--system/sbsigntools/git2tarxz.sh57
-rw-r--r--system/sbsigntools/sbsigntools.SlackBuild32
-rw-r--r--system/sbsigntools/sbsigntools.info10
-rw-r--r--system/sbsigntools/slack-desc2
5 files changed, 83 insertions, 23 deletions
diff --git a/system/sbsigntools/README b/system/sbsigntools/README
index 491bdcbb5a..54aec01b79 100644
--- a/system/sbsigntools/README
+++ b/system/sbsigntools/README
@@ -1 +1,4 @@
-sbsigntools is a set of tools for adding signatures.
+sbsigntools (signing utility for UEFI Secure Boot)
+
+sbsigntools is a set of tools for signing EFI binaries and drivers for
+use with Secure Boot.
diff --git a/system/sbsigntools/git2tarxz.sh b/system/sbsigntools/git2tarxz.sh
new file mode 100644
index 0000000000..a93ce8b4da
--- /dev/null
+++ b/system/sbsigntools/git2tarxz.sh
@@ -0,0 +1,57 @@
+#!/bin/sh
+
+# Create source tarball from git repo.
+
+# Takes one optional argument, which is the commit or tag to create a
+# tarball of. With no arg, HEAD is used.
+
+# Version number example: 0.0.1+20200227_ad7ec17
+
+# Notes:
+
+# This script doesn't need to be run as root. It does need to be able
+# to write to the current directory it's run from.
+
+# Running this script twice for the same commit will NOT give identical
+# tarballs, even if the contents are identical. This is because tar
+# includes the current time in a newly-created tarball (plus there may
+# be other git-related reasons).
+
+# Once you've generated a tarball, you'll still need a place to host it.
+# Ask on the mailing list, if you don't have your own web server to
+# play with.
+
+## Config:
+VERSION=0.9.5
+
+# final tarball and slackbuild PRGNAM:
+PRGNAM=sbsigntools
+
+# what it says on the tin:
+CLONE_URL=https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git
+
+## End of config.
+
+set -e
+
+GITDIR=$( mktemp -dt $PRGNAM.git.XXXXXX )
+rm -rf $GITDIR
+git clone --recursive $CLONE_URL $GITDIR
+
+CWD="$( pwd )"
+cd $GITDIR
+
+git reset --hard "v$VERSION"
+
+rm -rf .git
+find . -name .gitignore -print0 | xargs -0 rm -f
+
+cd "$CWD"
+rm -rf $PRGNAM-$VERSION $PRGNAM-$VERSION.tar.xz
+mv $GITDIR $PRGNAM-$VERSION
+tar cvfJ $PRGNAM-$VERSION.tar.xz $PRGNAM-$VERSION
+
+echo
+echo "Created tarball: $PRGNAM-$VERSION.tar.xz"
+echo "VERSION=\"$VERSION\""
+echo "MD5SUM=\"$( md5sum $PRGNAM-$VERSION.tar.xz | cut -d' ' -f1 )\""
diff --git a/system/sbsigntools/sbsigntools.SlackBuild b/system/sbsigntools/sbsigntools.SlackBuild
index 7f5deaac5f..9146f824f6 100644
--- a/system/sbsigntools/sbsigntools.SlackBuild
+++ b/system/sbsigntools/sbsigntools.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for sbsigntools
# Copyright 2015 Jonathan Li
+# Copyright 2023 Sam Wright
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +23,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20231211 bkw:
+# - update for v0.9.5.
+# - new maintainer (who isn't me, for once!)
+# - remove 0-byte ChangeLog from doc dir.
+# - various minor tweaks.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sbsigntools
-VERSION=${VERSION:-0.9.1}
+VERSION=${VERSION:-0.9.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +45,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -70,15 +74,16 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-# The tarball is generated from a clone --recursive of the git repository
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+# The tarball is generated from a clone --recursive of the git repository,
+# see git2tarxz.sh.
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
sed -i "s|/usr/lib$LIBDIRSUFFIX/efi|/usr/lib$LIBDIRSUFFIX/gnuefi|" configure.ac
@@ -95,16 +100,11 @@ CXXFLAGS="$SLKCFLAGS" \
cp lib/ccan.git/config.h lib/ccan
make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+make install-strip DESTDIR=$PKG
+gzip -9 $PKG/usr/man/man*/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING LICENSE.GPLv3 ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING LICENSE.GPLv3 $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/sbsigntools/sbsigntools.info b/system/sbsigntools/sbsigntools.info
index 52bbf91726..edb9bb25f7 100644
--- a/system/sbsigntools/sbsigntools.info
+++ b/system/sbsigntools/sbsigntools.info
@@ -1,10 +1,10 @@
PRGNAM="sbsigntools"
-VERSION="0.9.1"
+VERSION="0.9.5"
HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jejb/sbsigntools.git/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/sbsigntools-0.9.1.tar.xz"
-MD5SUM="3dbdb509be9310523377dc523d4b5bd7"
+DOWNLOAD="https://slackware.uk/~urchlay/src/sbsigntools-0.9.5.tar.xz"
+MD5SUM="a85d3283ddf70b6daac7f9e9601355b4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Jonathan Li"
-EMAIL="jonathan dot li at hotmail dot co dot uk"
+MAINTAINER="Sam Wright"
+EMAIL="proaudiomanuk@gmail.com"
diff --git a/system/sbsigntools/slack-desc b/system/sbsigntools/slack-desc
index e577aa4398..f0674c85c1 100644
--- a/system/sbsigntools/slack-desc
+++ b/system/sbsigntools/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-sbsigntools: sbsigntools (Signing utility for UEFI Secure Boot)
+sbsigntools: sbsigntools (signing utility for UEFI Secure Boot)
sbsigntools:
sbsigntools: sbsigntools is a set of tools for signing EFI binaries and drivers
sbsigntools: for use with Secure Boot.