summaryrefslogtreecommitdiffstats
path: root/system/sandbox
diff options
context:
space:
mode:
author Hunter Sezen2018-12-07 17:02:32 +0100
committer Willy Sudiarto Raharjo2018-12-07 17:02:32 +0100
commit81eb812b39db3f955b1abeb79e189f93bb7c0cd6 (patch)
tree561ec88817743ca62355f925363862a6888746f4 /system/sandbox
parent3d6809694f058b433d67d96cf42524ec33611f06 (diff)
downloadslackbuilds-81eb812b39db3f955b1abeb79e189f93bb7c0cd6.tar.gz
system/sandbox: Updated for version 2.14.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/sandbox')
-rw-r--r--system/sandbox/sandbox.SlackBuild16
-rw-r--r--system/sandbox/sandbox.info6
-rw-r--r--system/sandbox/slibtool.patch11
3 files changed, 8 insertions, 25 deletions
diff --git a/system/sandbox/sandbox.SlackBuild b/system/sandbox/sandbox.SlackBuild
index c53e008657..a6dbbd7181 100644
--- a/system/sandbox/sandbox.SlackBuild
+++ b/system/sandbox/sandbox.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sandbox
-VERSION=${VERSION:-2.13}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.14}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,11 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Remove -nodefaultlibs to avoid compiler failures for 32-bit with slibtool.
-# GNU libtool swallows anything not on their list of "known" linker flags.
-# https://bugs.gentoo.org/657184
-patch -p1 < $CWD/slibtool.patch
-
autoreconf -fi
CFLAGS="$SLKCFLAGS" \
@@ -90,12 +85,11 @@ make install DESTDIR=$PKG
mv $PKG/etc/$PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
mv $PKG/etc/$PRGNAM.d/00default $PKG/etc/$PRGNAM.d/00default.new
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog.0 INSTALL NEWS README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/sandbox/sandbox.info b/system/sandbox/sandbox.info
index bd2bb3927f..0c4d5d4623 100644
--- a/system/sandbox/sandbox.info
+++ b/system/sandbox/sandbox.info
@@ -1,8 +1,8 @@
PRGNAM="sandbox"
-VERSION="2.13"
+VERSION="2.14"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
-DOWNLOAD="https://gitweb.gentoo.org/proj/sandbox.git/snapshot/sandbox-2.13.tar.bz2"
-MD5SUM="827d62f76e531c77a6b90cf53be50f57"
+DOWNLOAD="https://gitweb.gentoo.org/proj/sandbox.git/snapshot/sandbox-2.14.tar.bz2"
+MD5SUM="a7a3f34ce12cd67e69326d13cc042362"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/sandbox/slibtool.patch b/system/sandbox/slibtool.patch
deleted file mode 100644
index bf12277a20..0000000000
--- a/system/sandbox/slibtool.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ur sandbox-2.13.orig/libsandbox/Makefile.am sandbox-2.13/libsandbox/Makefile.am
---- sandbox-2.13.orig/libsandbox/Makefile.am 2018-02-19 05:50:18.000000000 -0000
-+++ sandbox-2.13/libsandbox/Makefile.am 2018-06-03 12:58:04.270611236 -0000
-@@ -20,7 +20,6 @@
- # and destructor will not be executed ...
- libsandbox_la_LDFLAGS = \
- -no-undefined \
-- -nodefaultlibs \
- -avoid-version \
- $(LDFLAG_VER),libsandbox.map
- libsandbox_la_SOURCES = \