summaryrefslogtreecommitdiffstats
path: root/system/qemu
diff options
context:
space:
mode:
author Edward W. Koenig2021-02-16 00:31:25 +0100
committer Robby Workman2021-04-18 06:56:15 +0200
commit25c72e4ef12cae2818e1f6c3505b93207abdbbb3 (patch)
tree9d6ff5cb188037c8330358402ecd544d29fcf7a5 /system/qemu
parent8fd15ff59d1e5dd8f8275f795da5e13aa2d34f50 (diff)
downloadslackbuilds-25c72e4ef12cae2818e1f6c3505b93207abdbbb3.tar.gz
system/qemu: Patch for binutils-2.36.x.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system/qemu')
-rw-r--r--system/qemu/linker-no-pie.patch40
-rw-r--r--system/qemu/qemu.SlackBuild5
2 files changed, 45 insertions, 0 deletions
diff --git a/system/qemu/linker-no-pie.patch b/system/qemu/linker-no-pie.patch
new file mode 100644
index 0000000000..615d9a4ffa
--- /dev/null
+++ b/system/qemu/linker-no-pie.patch
@@ -0,0 +1,40 @@
+diff --git a/configure b/configure
+index 3f823ed163..61c17c2dde 100755
+--- a/configure
++++ b/configure
+@@ -2133,7 +2133,6 @@ EOF
+ # Check we support --no-pie first; we will need this for building ROMs.
+ if compile_prog "-Werror -fno-pie" "-no-pie"; then
+ CFLAGS_NOPIE="-fno-pie"
+- LDFLAGS_NOPIE="-no-pie"
+ fi
+
+ if test "$static" = "yes"; then
+@@ -2149,7 +2148,6 @@ if test "$static" = "yes"; then
+ fi
+ elif test "$pie" = "no"; then
+ CONFIGURE_CFLAGS="$CFLAGS_NOPIE $CONFIGURE_CFLAGS"
+- CONFIGURE_LDFLAGS="$LDFLAGS_NOPIE $CONFIGURE_LDFLAGS"
+ elif compile_prog "-Werror -fPIE -DPIE" "-pie"; then
+ CONFIGURE_CFLAGS="-fPIE -DPIE $CONFIGURE_CFLAGS"
+ CONFIGURE_LDFLAGS="-pie $CONFIGURE_LDFLAGS"
+@@ -6768,7 +6766,6 @@ echo "QEMU_CXXFLAGS=$QEMU_CXXFLAGS" >> $config_host_mak
+ echo "GLIB_CFLAGS=$glib_cflags" >> $config_host_mak
+ echo "GLIB_LIBS=$glib_libs" >> $config_host_mak
+ echo "QEMU_LDFLAGS=$QEMU_LDFLAGS" >> $config_host_mak
+-echo "LDFLAGS_NOPIE=$LDFLAGS_NOPIE" >> $config_host_mak
+ echo "LD_I386_EMULATION=$ld_i386_emulation" >> $config_host_mak
+ echo "EXESUF=$EXESUF" >> $config_host_mak
+ echo "HOST_DSOSUF=$HOST_DSOSUF" >> $config_host_mak
+diff --git a/pc-bios/optionrom/Makefile b/pc-bios/optionrom/Makefile
+index 084fc10f05..30771f8d17 100644
+--- a/pc-bios/optionrom/Makefile
++++ b/pc-bios/optionrom/Makefile
+@@ -41,7 +41,6 @@ override CFLAGS += $(call cc-option, $(Wa)-32)
+
+ LD_I386_EMULATION ?= elf_i386
+ override LDFLAGS = -m $(LD_I386_EMULATION) -T $(SRC_DIR)/flat.lds
+-override LDFLAGS += $(LDFLAGS_NOPIE)
+
+ all: multiboot.bin linuxboot.bin linuxboot_dma.bin kvmvapic.bin pvh.bin
+
diff --git a/system/qemu/qemu.SlackBuild b/system/qemu/qemu.SlackBuild
index 57a43b834a..e53cb9792d 100644
--- a/system/qemu/qemu.SlackBuild
+++ b/system/qemu/qemu.SlackBuild
@@ -135,6 +135,11 @@ else
with_vnc="--disable-vnc"
fi
+# temp fix until upstream catches up.
+# ld: Error: unable to disambiguate: -no-pie (did you mean --no-pie ?)
+# https://lists.gnu.org/archive/html/qemu-devel/2020-12/msg03684.html
+patch -p1 < $CWD/linker-no-pie.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \