summaryrefslogtreecommitdiffstats
path: root/system/python3-nvidia-ml-py
diff options
context:
space:
mode:
author Lockywolf2023-11-30 16:39:37 +0100
committer Willy Sudiarto Raharjo2023-11-30 17:02:09 +0100
commit0ae2bab31e49ad9d53d7a58275d0c1c63eb834c8 (patch)
tree7539e7641efc00e83aaa6c7e8374e47b94efeafb /system/python3-nvidia-ml-py
parent9a097861ee4e40260761cbc9facaa2dc07cdea5a (diff)
downloadslackbuilds-0ae2bab31e49ad9d53d7a58275d0c1c63eb834c8.tar.gz
system/python3-nvidia-ml-py: Added (Python Bindings for NVIDIA ML).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/python3-nvidia-ml-py')
-rw-r--r--system/python3-nvidia-ml-py/README21
-rw-r--r--system/python3-nvidia-ml-py/python3-nvidia-ml-py.SlackBuild106
-rw-r--r--system/python3-nvidia-ml-py/python3-nvidia-ml-py.info10
-rw-r--r--system/python3-nvidia-ml-py/slack-desc19
4 files changed, 156 insertions, 0 deletions
diff --git a/system/python3-nvidia-ml-py/README b/system/python3-nvidia-ml-py/README
new file mode 100644
index 0000000000..cd088ab039
--- /dev/null
+++ b/system/python3-nvidia-ml-py/README
@@ -0,0 +1,21 @@
+pyNVML
+
+Python bindings to the NVIDIA Management Library
+Provides a Python interface to GPU management and monitoring functions.
+
+This is a wrapper around the NVML library. For information about the
+NVML library, see the NVML developer page
+http://developer.nvidia.com/nvidia-management-library-nvml
+
+Download the latest package from:
+http://pypi.python.org/pypi/nvidia-ml-py/
+
+
+The nvml header file contains function documentation that is relevant to
+this wrapper. The header file is distributed with.
+https://developer.nvidia.com/gpu-deployment-kit
+
+The main difference is this library handles allocating structs and
+passing pointers to the functions, before returning the desired value.
+Non-success return codes are raised as exceptions as described in the
+section below.
diff --git a/system/python3-nvidia-ml-py/python3-nvidia-ml-py.SlackBuild b/system/python3-nvidia-ml-py/python3-nvidia-ml-py.SlackBuild
new file mode 100644
index 0000000000..56701e8ea9
--- /dev/null
+++ b/system/python3-nvidia-ml-py/python3-nvidia-ml-py.SlackBuild
@@ -0,0 +1,106 @@
+#!/bin/bash
+
+# Slackware build script for python3-nvidia-ml-py
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-nvidia-ml-py
+TARNAM=nvidia-ml-py
+VERSION=${VERSION:-12.535.133}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TARNAM-$VERSION
+tar xvf $CWD/$TARNAM-$VERSION.tar.gz
+cd $TARNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+python3 setup.py install --root=$PKG
+
+## If your application only has a pyproject.toml:
+
+#python3 -m build --wheel --no-isolation
+
+#python3 -m installer --destdir "$PKG" dist/*.whl
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/lib${LIBDIRSUFFIX}/python3.9/site-packages/example.py $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/python3-nvidia-ml-py/python3-nvidia-ml-py.info b/system/python3-nvidia-ml-py/python3-nvidia-ml-py.info
new file mode 100644
index 0000000000..4f8abf8b63
--- /dev/null
+++ b/system/python3-nvidia-ml-py/python3-nvidia-ml-py.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-nvidia-ml-py"
+VERSION="12.535.133"
+HOMEPAGE="https://pypi.org/project/nvidia-ml-py/"
+DOWNLOAD="https://files.pythonhosted.org/packages/c9/f5/35d8002a4a9532c58fa304046de2d9b8be18183c341c517ac48f2bce907a/nvidia-ml-py-12.535.133.tar.gz"
+MD5SUM="64e3bc3b8718767771d5d366a3109cba"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.nvidia-ml-py_2023-11-28@lockywolf.net"
diff --git a/system/python3-nvidia-ml-py/slack-desc b/system/python3-nvidia-ml-py/slack-desc
new file mode 100644
index 0000000000..8de51ef212
--- /dev/null
+++ b/system/python3-nvidia-ml-py/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-nvidia-ml-py: python3-nvidia-ml-py (bindings to the NVIDIA Management Library)
+python3-nvidia-ml-py:
+python3-nvidia-ml-py: Provides a Python interface to GPU management and monitoring
+python3-nvidia-ml-py: functions. This is a wrapper around the NVML library. For
+python3-nvidia-ml-py: information about the NVML library, see the NVML developer page
+python3-nvidia-ml-py: http://developer.nvidia.com/nvidia-management-library-nvml
+python3-nvidia-ml-py:
+python3-nvidia-ml-py:
+python3-nvidia-ml-py:
+python3-nvidia-ml-py:
+python3-nvidia-ml-py: