summaryrefslogtreecommitdiffstats
path: root/system/pbzip2
diff options
context:
space:
mode:
author Erik Hanson2010-05-11 15:18:42 +0200
committer Michiel van Wessem2010-05-11 15:18:42 +0200
commitf3a34d376ecea15be8eb56a386317d25f2e67249 (patch)
tree15134fd07700a02afa915aed62cda2011344d111 /system/pbzip2
parentcd62035bc1960706731969e45a0a7a776e1b5d97 (diff)
downloadslackbuilds-f3a34d376ecea15be8eb56a386317d25f2e67249.tar.gz
system/pbzip2: Initial import
Diffstat (limited to 'system/pbzip2')
-rw-r--r--system/pbzip2/Makefile.patch22
-rw-r--r--system/pbzip2/README10
-rw-r--r--system/pbzip2/pbzip2.SlackBuild47
-rw-r--r--system/pbzip2/pbzip2.info8
-rw-r--r--system/pbzip2/slack-desc11
5 files changed, 98 insertions, 0 deletions
diff --git a/system/pbzip2/Makefile.patch b/system/pbzip2/Makefile.patch
new file mode 100644
index 0000000000..ef935dc8c1
--- /dev/null
+++ b/system/pbzip2/Makefile.patch
@@ -0,0 +1,22 @@
+--- Makefile 2007-03-14 15:59:20.000000000 -0500
++++ Makefile.new 2007-03-14 16:00:29.000000000 -0500
+@@ -11,16 +11,16 @@
+
+ # Standard pbzip2 compile
+ pbzip2: pbzip2.cpp
+- $(CC) -O3 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
++ $(CC) -O3 -march=i486 -mtune=i686 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
+
+ # Choose this if you want to compile in a static version of the libbz2 library
+ pbzip2-static: libbz2.a pbzip2.cpp
+- $(CC) -O3 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -I. -L. -lbz2
++ $(CC) -O3 -march=i486 -mtune=i686 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -I. -L. -lbz2
+
+ # Compatability mode for 32bit file sizes (less than 2GB) and systems
+ # that have compilers that treat int as 64bit natively (ie: modern AIX)
+ pbzip2-compat: pbzip2.cpp
+- $(CC) -O3 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
++ $(CC) -O3 -march=i486 -mtune=i686 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
+
+ # Install the binary pbzip2 program and man page
+ install: pbzip2
diff --git a/system/pbzip2/README b/system/pbzip2/README
new file mode 100644
index 0000000000..f5cdb8f284
--- /dev/null
+++ b/system/pbzip2/README
@@ -0,0 +1,10 @@
+Parallel BZIP2 (PBZIP2) - Data Compression Software
+
+PBZIP2 is a parallel implementation of the bzip2 block-sorting file compressor
+that uses pthreads and achieves near-linear speedup on SMP machines. The
+output of this version is fully compatible with bzip2 v1.0.2 or newer (ie:
+anything compressed with pbzip2 can be decompressed with bzip2).
+
+PBZIP2 should work on any system that has a pthreads compatible C++ compiler
+(such as gcc). It has been tested on: Linux, Windows (cygwin & MinGW),
+Solaris, Tru64/OSF1, HP-UX, and Irix.
diff --git a/system/pbzip2/pbzip2.SlackBuild b/system/pbzip2/pbzip2.SlackBuild
new file mode 100644
index 0000000000..b4e34c3bb8
--- /dev/null
+++ b/system/pbzip2/pbzip2.SlackBuild
@@ -0,0 +1,47 @@
+#!/bin/sh
+
+# Slackware build script for PBZIP2
+# Written by Erik Hanson erik@slackbuilds.org
+
+PRGNAM=pbzip2
+VERSION=1.0
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Patch to add march/mtune
+patch -p0 < $CWD/Makefile.patch
+make || exit 1
+
+# DESTDIR isn't support, there's only 2 files so install manually
+mkdir -p $PKG/usr/{bin,man/man1,doc/$PRGNAM-$VERSION} $PKG/install
+
+# Binary
+cp pbzip2 $PKG/usr/bin/pbzip2
+strip --strip-unneeded $PKG/usr/bin/pbzip2 2> /dev/null
+chmod a+x $PKG/usr/bin/pbzip2
+
+# Man page
+cp pbzip2.1 $PKG/usr/man/man1
+gzip -9 $PKG/usr/man/man1/pbzip2.1
+chmod a+r $PKG/usr/man/man1/pbzip2.1.gz
+
+cp -a AUTHORS COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/pbzip2/pbzip2.info b/system/pbzip2/pbzip2.info
new file mode 100644
index 0000000000..e7cf9e6852
--- /dev/null
+++ b/system/pbzip2/pbzip2.info
@@ -0,0 +1,8 @@
+PRGNAM="pbzip2"
+VERSION="1.0"
+HOMEPAGE="http://compression.ca/pbzip2/"
+DOWNLOAD="http://compression.ca/pbzip2/pbzip2-1.0.tar.gz"
+MD5SUM="a8923165b97e665b9d1e85f1566700e9"
+MAINTAINER="Erik Hanson"
+EMAIL="erik@slackbuilds.org"
+APPROVED="BP{k}"
diff --git a/system/pbzip2/slack-desc b/system/pbzip2/slack-desc
new file mode 100644
index 0000000000..f331920c34
--- /dev/null
+++ b/system/pbzip2/slack-desc
@@ -0,0 +1,11 @@
+pbzip2: PBZIP2 - Parallel BZIP2
+pbzip2:
+pbzip2: PBZIP2 is a parallel implementation of the bzip2 block-sorting file
+pbzip2: compressor that uses pthreads and achieves near-linear speedup on SMP
+pbzip2: machines. The output of this version is fully compatible with bzip2
+pbzip2: v1.0.2 or newer (ie: anything compressed with pbzip2 can be
+pbzip2: decompressed with bzip2).
+pbzip2:
+pbzip2:
+pbzip2:
+pbzip2: