summaryrefslogtreecommitdiffstats
path: root/system/onerng
diff options
context:
space:
mode:
author pyllyukko2017-02-12 16:25:53 +0100
committer David Spencer2017-02-12 16:25:53 +0100
commit343a7a78fdaa80affbc22265c4830a41b92887ab (patch)
tree65f0d0d81c2154a0858048dbd379761a38c67f3b /system/onerng
parent2f1761220db12fad6b31fd3420cf5e8c093e661d (diff)
downloadslackbuilds-343a7a78fdaa80affbc22265c4830a41b92887ab.tar.gz
system/onerng: Added (entropy generator).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system/onerng')
-rw-r--r--system/onerng/README8
-rw-r--r--system/onerng/doinst.sh14
-rw-r--r--system/onerng/onerng.SlackBuild98
-rw-r--r--system/onerng/onerng.info10
-rw-r--r--system/onerng/slack-desc19
5 files changed, 149 insertions, 0 deletions
diff --git a/system/onerng/README b/system/onerng/README
new file mode 100644
index 0000000000..53cb42bb0e
--- /dev/null
+++ b/system/onerng/README
@@ -0,0 +1,8 @@
+OneRNG (entropy generator)
+
+The OneRNG entropy generator is a USB dongle that creates a stream of
+data suitable for feeding to your kernel's entropy service. The device
+does not need a special kernel driver.
+
+This package installs a udev script that starts the rngd entropy
+daemon when a OneRNG is plugged in.
diff --git a/system/onerng/doinst.sh b/system/onerng/doinst.sh
new file mode 100644
index 0000000000..2fec62be61
--- /dev/null
+++ b/system/onerng/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/onerng.conf.new
diff --git a/system/onerng/onerng.SlackBuild b/system/onerng/onerng.SlackBuild
new file mode 100644
index 0000000000..765e11b7e1
--- /dev/null
+++ b/system/onerng/onerng.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for OneRNG
+
+# Copyright 2016 pyllyukko
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=onerng
+VERSION=${VERSION:-3.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_${VERSION}.orig.tar.gz
+cd ${PRGNAM}_${VERSION}
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --build=$ARCH-slackware-linux
+
+make
+# fix the .conf -> .conf.new
+sed -i 's:^\(.*onerngconfSCRIPT_INSTALL.*$(DESTDIR)$(onerngconfdir)/$$f\)\(.*\)$:\1.new\2:' files/Makefile
+make install-strip DESTDIR=$PKG
+
+mkdir -p ${PKG}/usr/doc/${PRGNAM}-${VERSION}
+cp -a \
+ AUTHORS COPYING ChangeLog INSTALL NEWS README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/onerng/onerng.info b/system/onerng/onerng.info
new file mode 100644
index 0000000000..23a856e17f
--- /dev/null
+++ b/system/onerng/onerng.info
@@ -0,0 +1,10 @@
+PRGNAM="onerng"
+VERSION="3.4"
+HOMEPAGE="http://www.onerng.info"
+DOWNLOAD="https://github.com/OneRNG/onerng.github.io/raw/master/sw/onerng_3.4.orig.tar.gz"
+MD5SUM="cbd942523ac5322043932abc9f3616af"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-gnupg rng-tools"
+MAINTAINER="pyllyukko"
+EMAIL="pyllyukko AT maimed dot org"
diff --git a/system/onerng/slack-desc b/system/onerng/slack-desc
new file mode 100644
index 0000000000..48e279204e
--- /dev/null
+++ b/system/onerng/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+onerng: onerng (entropy generator)
+onerng:
+onerng: The OneRNG entropy generator is a USB dongle that creates a stream of
+onerng: data suitable for feeding to your kernel's entropy service. The device
+onerng: does not need a special kernel driver.
+onerng:
+onerng: This package installs a udev script that starts the rngd entropy
+onerng: daemon when a OneRNG is plugged in.
+onerng:
+onerng: More information can be found at: http://www.onerng.info
+onerng: