summaryrefslogtreecommitdiffstats
path: root/system/letsencrypt
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2020-01-18 01:59:20 +0100
committer Willy Sudiarto Raharjo2020-01-19 02:53:10 +0100
commitc49d9f10b523508bf99aed3ffd169f0522d95931 (patch)
tree625632ae0645af77395f89bd87af5f6fecf447ea /system/letsencrypt
parente7c5997b9311a3ac31e986a3d4f525c9af840c89 (diff)
downloadslackbuilds-c49d9f10b523508bf99aed3ffd169f0522d95931.tar.gz
system/letsencrypt: Updated for version 1.1.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/letsencrypt')
-rw-r--r--system/letsencrypt/README5
-rw-r--r--system/letsencrypt/letsencrypt.SlackBuild14
-rw-r--r--system/letsencrypt/letsencrypt.info8
3 files changed, 16 insertions, 11 deletions
diff --git a/system/letsencrypt/README b/system/letsencrypt/README
index 96337ef219..22f8a1a147 100644
--- a/system/letsencrypt/README
+++ b/system/letsencrypt/README
@@ -8,3 +8,8 @@ See README.Slackware for more detailed instructions.
Note: the certificate client tool is now certbot, but a symlink is provided
to be backward compatible with previous letsencrypt version.
Please rename the script to the new name: certbot
+
+Since 1.1.0, most of deps must be (re)built against Python3.
+While most of the scripts have python3 support already, some scripts have to be
+installed using custom parameter (PYTHON3=yes):
+- psutil
diff --git a/system/letsencrypt/letsencrypt.SlackBuild b/system/letsencrypt/letsencrypt.SlackBuild
index 6c4c002267..efa6a48fea 100644
--- a/system/letsencrypt/letsencrypt.SlackBuild
+++ b/system/letsencrypt/letsencrypt.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for letsencrypt
-# Copyright 2015-2019 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015-2020 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=letsencrypt
SRCNAM=certbot
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -80,24 +80,24 @@ done
# install acme-protocol first
cd acme
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
# install letsencrypt client
cd ../certbot
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
# install apache plugin
cd ../certbot-apache
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
cd ..
# install nginx plugin
#cd ../certbot-nginx
-#python setup.py install --root=$PKG
+#python3 setup.py install --root=$PKG
# We include default options for Apache
mkdir -p $PKG/etc/letsencrypt/
-cp $PKG/usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/certbot_apache/_internal/options-ssl-apache.conf \
+cp $PKG/usr/lib${LIBDIRSUFFIX}/python3.7/site-packages/certbot_apache/_internal/options-ssl-apache.conf \
$PKG/etc/letsencrypt/options-ssl-apache.conf
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/system/letsencrypt/letsencrypt.info b/system/letsencrypt/letsencrypt.info
index 021f11f9ea..fef0763e76 100644
--- a/system/letsencrypt/letsencrypt.info
+++ b/system/letsencrypt/letsencrypt.info
@@ -1,10 +1,10 @@
PRGNAM="letsencrypt"
-VERSION="1.0.0"
+VERSION="1.1.0"
HOMEPAGE="https://letsencrypt.org/"
-DOWNLOAD="https://github.com/certbot/certbot/archive/v1.0.0/certbot-1.0.0.tar.gz"
-MD5SUM="b315bc17f96689f729b2e72366658709"
+DOWNLOAD="https://github.com/certbot/certbot/archive/v1.1.0/certbot-1.1.0.tar.gz"
+MD5SUM="7ad231b513910a0e8d2d8d32365589d5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="configobj mock pytz python2-pythondialog zope.component pyrfc3339 psutil python-parsedatetime python-configargparse werkzeug ndg_httpsclient python-augeas pyparsing josepy funcsigs requests-toolbelt python-distro"
+REQUIRES="configobj mock pytz python3-pythondialog zope.component pyrfc3339 psutil python-parsedatetime python-configargparse werkzeug ndg_httpsclient python3-augeas josepy funcsigs requests-toolbelt python-distro python3-certifi python3-packaging"
MAINTAINER="Willy Sudiarto Raharjo"
EMAIL="willysr@slackbuilds.org"