summaryrefslogtreecommitdiffstats
path: root/system/letsencrypt/letsencrypt.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2020-01-18 01:59:20 +0100
committer Willy Sudiarto Raharjo2020-01-19 02:53:10 +0100
commitc49d9f10b523508bf99aed3ffd169f0522d95931 (patch)
tree625632ae0645af77395f89bd87af5f6fecf447ea /system/letsencrypt/letsencrypt.SlackBuild
parente7c5997b9311a3ac31e986a3d4f525c9af840c89 (diff)
downloadslackbuilds-c49d9f10b523508bf99aed3ffd169f0522d95931.tar.gz
system/letsencrypt: Updated for version 1.1.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/letsencrypt/letsencrypt.SlackBuild')
-rw-r--r--system/letsencrypt/letsencrypt.SlackBuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/system/letsencrypt/letsencrypt.SlackBuild b/system/letsencrypt/letsencrypt.SlackBuild
index 6c4c002267..efa6a48fea 100644
--- a/system/letsencrypt/letsencrypt.SlackBuild
+++ b/system/letsencrypt/letsencrypt.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for letsencrypt
-# Copyright 2015-2019 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015-2020 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=letsencrypt
SRCNAM=certbot
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -80,24 +80,24 @@ done
# install acme-protocol first
cd acme
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
# install letsencrypt client
cd ../certbot
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
# install apache plugin
cd ../certbot-apache
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
cd ..
# install nginx plugin
#cd ../certbot-nginx
-#python setup.py install --root=$PKG
+#python3 setup.py install --root=$PKG
# We include default options for Apache
mkdir -p $PKG/etc/letsencrypt/
-cp $PKG/usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/certbot_apache/_internal/options-ssl-apache.conf \
+cp $PKG/usr/lib${LIBDIRSUFFIX}/python3.7/site-packages/certbot_apache/_internal/options-ssl-apache.conf \
$PKG/etc/letsencrypt/options-ssl-apache.conf
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \