summaryrefslogtreecommitdiffstats
path: root/system/letsencrypt/letsencrypt.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2019-12-07 15:01:51 +0100
committer Willy Sudiarto Raharjo2019-12-07 15:01:51 +0100
commitac874e53cfc0e799c8d2cbd7837f6e133d373229 (patch)
treeb39cb9fb73dc29991408201802ffcbd2c9513261 /system/letsencrypt/letsencrypt.SlackBuild
parent3f7cc3a93c7e137b55f3791cc4ce9632daccab10 (diff)
downloadslackbuilds-ac874e53cfc0e799c8d2cbd7837f6e133d373229.tar.gz
system/letsencrypt: Updated for version 1.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/letsencrypt/letsencrypt.SlackBuild')
-rw-r--r--system/letsencrypt/letsencrypt.SlackBuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/system/letsencrypt/letsencrypt.SlackBuild b/system/letsencrypt/letsencrypt.SlackBuild
index b95865dce7..6c4c002267 100644
--- a/system/letsencrypt/letsencrypt.SlackBuild
+++ b/system/letsencrypt/letsencrypt.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=letsencrypt
SRCNAM=certbot
-VERSION=${VERSION:-0.40.1}
+VERSION=${VERSION:-1.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,9 +70,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i "/'argparse',/d" setup.py
+sed -i "/'argparse',/d" certbot/setup.py
sed -i "/'argparse',/d" acme/setup.py
-sed -i 's/apache2ctl/apachectl/' certbot-apache/certbot_apache/constants.py
for i in $(grep -ri /apache2 * | cut -d: -f1 | sort -u)
do
@@ -84,13 +83,11 @@ cd acme
python setup.py install --root=$PKG
# install letsencrypt client
-cd ..
+cd ../certbot
python setup.py install --root=$PKG
-# this plugins are not working for Slackware yet, but we will keep it here
-
# install apache plugin
-cd certbot-apache
+cd ../certbot-apache
python setup.py install --root=$PKG
cd ..
@@ -100,14 +97,14 @@ cd ..
# We include default options for Apache
mkdir -p $PKG/etc/letsencrypt/
-cp $PKG/usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/certbot_apache/options-ssl-apache.conf \
+cp $PKG/usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/certbot_apache/_internal/options-ssl-apache.conf \
$PKG/etc/letsencrypt/options-ssl-apache.conf
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.rst *.md *.txt *.in $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst *.md *.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cd $PKG/usr/bin