summaryrefslogtreecommitdiffstats
path: root/system/letsencrypt/letsencrypt.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2017-05-14 04:55:23 +0200
committer Willy Sudiarto Raharjo2017-05-20 01:54:09 +0200
commit724cc20ed29e6de0fbb6511e786404c3bf2d43dd (patch)
tree5172e8d22980d2fc2a4b2f778482c83031568a76 /system/letsencrypt/letsencrypt.SlackBuild
parent1af8006c57249d388802fdfdecf8e247d8587ecb (diff)
downloadslackbuilds-724cc20ed29e6de0fbb6511e786404c3bf2d43dd.tar.gz
system/letsencrypt: Updated for version 0.14.1.
Apache Plugin is now enabled, Thanks to Eric Pratt. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/letsencrypt/letsencrypt.SlackBuild')
-rw-r--r--system/letsencrypt/letsencrypt.SlackBuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/system/letsencrypt/letsencrypt.SlackBuild b/system/letsencrypt/letsencrypt.SlackBuild
index ceefe5f90b..fbbec0c1c4 100644
--- a/system/letsencrypt/letsencrypt.SlackBuild
+++ b/system/letsencrypt/letsencrypt.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=letsencrypt
SRCNAM=certbot
-VERSION=${VERSION:-0.14.0}
+VERSION=${VERSION:-0.14.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,6 +72,12 @@ find -L . \
sed -i "/'argparse',/d" setup.py
sed -i "/'argparse',/d" acme/setup.py
+sed -i 's/apache2ctl/apachectl/' certbot-apache/certbot_apache/constants.py
+
+for i in $(grep -ri /apache2 * | cut -d: -f1 | sort -u)
+do
+ sed -i 's/\/apache2/\/httpd/' $i
+done
# install acme-protocol first
cd acme
@@ -79,17 +85,17 @@ python setup.py install --root=$PKG
# install letsencrypt client
cd ..
-
python setup.py install --root=$PKG
# this plugins are not working for Slackware yet, but we will keep it here
# install apache plugin
-#cd letsencrypt-apache
-#python setup.py install --root=$PKG
+cd certbot-apache
+python setup.py install --root=$PKG
+cd ..
# install nginx plugin
-#cd ../letsencrypt-nginx
+#cd ../certbot-nginx
#python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \