summaryrefslogtreecommitdiffstats
path: root/system/gkrellm-volume/gkrellm-volume.SlackBuild
diff options
context:
space:
mode:
author Paul Wisehart2010-05-11 15:18:37 +0200
committer Robby Workman2010-05-11 15:18:37 +0200
commit4a1010775fc803757be03ad4affae301e5e2f364 (patch)
treeecf48966a2de04693b031979f3921e4cb77faa0b /system/gkrellm-volume/gkrellm-volume.SlackBuild
parentf5de26e6f50459ed5afe0f8ef1438f4b5213f440 (diff)
downloadslackbuilds-4a1010775fc803757be03ad4affae301e5e2f364.tar.gz
system/gkrellm-volume: Initial import
Diffstat (limited to 'system/gkrellm-volume/gkrellm-volume.SlackBuild')
-rw-r--r--system/gkrellm-volume/gkrellm-volume.SlackBuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/system/gkrellm-volume/gkrellm-volume.SlackBuild b/system/gkrellm-volume/gkrellm-volume.SlackBuild
new file mode 100644
index 0000000000..d67fc3a2ed
--- /dev/null
+++ b/system/gkrellm-volume/gkrellm-volume.SlackBuild
@@ -0,0 +1,63 @@
+#!/bin/sh
+
+### gkrellm-volume.SlackBuild ###
+
+# Slackware build script for gkrellm-volume 2.1.13
+# Copyright (C) 2006 paul wisehart wise@lupulin.net
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# Modifed by the SlackBuilds.org project
+
+PKGNAME=gkrellm-volume
+VERSION=2.1.13
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PKGNAME
+OUTPUT=${OUTPUT:-/tmp} # Final location of package
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PKGNAME-$VERSION
+tar -xvzf $CWD/$PKGNAME-$VERSION.tar.gz || exit 1
+cd $PKGNAME || exit 1
+chown -R root:root .
+chmod -R a-s,u+w,go+r-w .
+
+# Patch the Makefile and po/Makefile to support DESTDIR
+cat $CWD/Makefile.diff | patch -p1 --verbose || exit 1
+
+make enable_nls=1 enable_alsa=1 || exit 1
+make enable_nls=1 enable_alsa=1 install DESTDIR=$PKG || exit 1
+
+# Strip the .so file
+strip --strip-unneeded $PKG/usr/lib/gkrellm2/plugins/volume.so
+
+mkdir -p $PKG/usr/doc/$PKGNAME-$VERSION
+cp -a COPYRIGHT Changelog README THEMING $PKG/usr/doc/$PKGNAME-$VERSION
+cp -a po/README $PKG/usr/doc/$PKGNAME-$VERSION/README.po
+cat $CWD/$PKGNAME.SlackBuild > $PKG/usr/doc/$PKGNAME-$VERSION/$PKGNAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PKGNAME-$VERSION-$ARCH-$BUILD$TAG.tgz