summaryrefslogtreecommitdiffstats
path: root/system/fprintd
diff options
context:
space:
mode:
author Fabio Bas2022-04-30 01:17:53 +0200
committer Willy Sudiarto Raharjo2022-04-30 08:51:59 +0200
commit4b56a5344508e8530736c64ad4214b112f6aebb6 (patch)
tree769df13f2306fbbc3daff1a3fae7079366005b18 /system/fprintd
parent4e8e43b4134251b2b412d1f43b05300bb6c2618c (diff)
downloadslackbuilds-4b56a5344508e8530736c64ad4214b112f6aebb6.tar.gz
system/fprintd: Added (fingerprint scanning daemon over D-Bus)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/fprintd')
-rw-r--r--system/fprintd/README9
-rw-r--r--system/fprintd/doinst.sh14
-rw-r--r--system/fprintd/fprintd.SlackBuild124
-rw-r--r--system/fprintd/fprintd.info10
-rw-r--r--system/fprintd/slack-desc19
5 files changed, 176 insertions, 0 deletions
diff --git a/system/fprintd/README b/system/fprintd/README
new file mode 100644
index 0000000000..6e56d00df9
--- /dev/null
+++ b/system/fprintd/README
@@ -0,0 +1,9 @@
+fprintd is a daemon that provides fingerprint scanning functionality
+over D-Bus.
+This is the software developers will want to integrate with to add
+fingerprint authentication to OSes, desktop environments and
+applications.
+It also includes small command-line utilities if your desktop
+environment does not integrate support.
+A PAM module to implement user login (pam_fprintd) is unavailable on
+Slackware since it requires systemd.
diff --git a/system/fprintd/doinst.sh b/system/fprintd/doinst.sh
new file mode 100644
index 0000000000..4b387050ff
--- /dev/null
+++ b/system/fprintd/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/fprintd.conf.new
diff --git a/system/fprintd/fprintd.SlackBuild b/system/fprintd/fprintd.SlackBuild
new file mode 100644
index 0000000000..0f895acf79
--- /dev/null
+++ b/system/fprintd/fprintd.SlackBuild
@@ -0,0 +1,124 @@
+#!/bin/bash
+
+# Slackware build script for fprintd
+
+# Copyright 2022 Fabio Bas <ctrlaltca {at} gmail [dot] com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=fprintd
+VERSION=${VERSION:-1.94.2}
+SRCVERSION=v${VERSION}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVERSION
+tar xvf $CWD/$PRGNAM-$SRCVERSION.tar.gz
+cd $PRGNAM-$SRCVERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Disable tests since tehy require various python modules
+sed '154,158 {s/^/#/}' -i meson.build
+sed '204,205 {s/^/#/}' -i meson.build
+sed -e "/subdir('tests')/ s/^#*/#/" -i meson.build
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ -Dsystemd=false \
+ -Dpam=false \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ ninja
+ DESTDIR=$PKG ninja install
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/man
+mv $PKG/usr/share/man/man* $PKG/usr/man
+rmdir $PKG/usr/share/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+mv $PKG/etc/fprintd.conf $PKG/etc/fprintd.conf.new
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README TODO AUTHORS COPYING NEWS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/fprintd/fprintd.info b/system/fprintd/fprintd.info
new file mode 100644
index 0000000000..571462fadf
--- /dev/null
+++ b/system/fprintd/fprintd.info
@@ -0,0 +1,10 @@
+PRGNAM="fprintd"
+VERSION="1.94.2"
+HOMEPAGE="https://fprint.freedesktop.org/"
+DOWNLOAD="https://gitlab.freedesktop.org/libfprint/fprintd/-/archive/v1.94.2/fprintd-v1.94.2.tar.gz"
+MD5SUM="341566e629c70ab428d265f4dd3e00be"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libfprint"
+MAINTAINER="Fabio Bas"
+EMAIL="ctrlaltca <at> gmail {dot} com"
diff --git a/system/fprintd/slack-desc b/system/fprintd/slack-desc
new file mode 100644
index 0000000000..2f9579bca6
--- /dev/null
+++ b/system/fprintd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+fprintd: fprintd (fingerprint scanning daemon available over D-Bus)
+fprintd:
+fprintd: fprintd is a daemon that provides fingerprint scanning functionality
+fprintd: over D-Bus. This is the software developers will want to integrate
+fprintd: with to add fingerprint authentication to OSes, desktop environments
+fprintd: and applications.
+fprintd: It also includes small command-line utilities if your desktop
+fprintd: environment does not integrate support.
+fprintd: A PAM module to implement user login (pam_fprintd) is unavailable on
+fprintd: Slackware since it requires systemd.
+fprintd: URL: https://fprint.freedesktop.org/