summaryrefslogtreecommitdiffstats
path: root/system/fountain
diff options
context:
space:
mode:
author B. Watson2022-01-11 05:29:34 +0100
committer Willy Sudiarto Raharjo2022-01-17 03:03:28 +0100
commit9460a2396e3daa20c536faeaba07664db89ec4f4 (patch)
treeff21125b7b93374cab7eb660ff341482468a3ff4 /system/fountain
parentf74a16b46399fd6404f9ab5336783d464b300973 (diff)
downloadslackbuilds-9460a2396e3daa20c536faeaba07664db89ec4f4.tar.gz
system/fountain: Added (pipe stdin to multiple processes).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/fountain')
-rw-r--r--system/fountain/README5
-rw-r--r--system/fountain/fountain.SlackBuild136
-rw-r--r--system/fountain/fountain.info12
-rw-r--r--system/fountain/slack-desc19
4 files changed, 172 insertions, 0 deletions
diff --git a/system/fountain/README b/system/fountain/README
new file mode 100644
index 0000000000..5979c94d66
--- /dev/null
+++ b/system/fountain/README
@@ -0,0 +1,5 @@
+fountain (pipe standard input to multiple processes)
+
+Fountain take a single input stream and writes (pipes) it to multiple
+commands. This is similar to tee(1), except tee writes data to files;
+fountain runs commands and pipes data to them.
diff --git a/system/fountain/fountain.SlackBuild b/system/fountain/fountain.SlackBuild
new file mode 100644
index 0000000000..fa998770ae
--- /dev/null
+++ b/system/fountain/fountain.SlackBuild
@@ -0,0 +1,136 @@
+#!/bin/bash
+
+# Slackware build script for fountain
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# Notes:
+
+# I can't find an actual content-bearing homepage for this. It's a
+# very useful utility, so I packaged it up with a placeholder homepage.
+
+# The support library tracefct is just built statically and linked into
+# the executable. If ever there's a need for it, it could be broken out
+# into its own SlackBuild easily enough.
+
+# No idea why the man page is installed in section "l". I never heard
+# of this before. Wikipedia lists it as "LAPACK library functions",
+# which this most certainly isn't. So I moved it to section 1.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=fountain
+VERSION=${VERSION:-1.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+LIBNAM=tracefct
+LIBVER=${LIBVER:-1.0.10}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+tar xvf $CWD/$LIBNAM-$LIBVER.tar.gz
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+DOCDIR=/usr/doc/$PRGNAM-$VERSION
+PKGDOC=$PKG/$DOCDIR
+
+# don't see much point making this library a separate build.
+cd $LIBNAM-$LIBVER
+LIBINST="$(pwd)/inst"
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=$LIBINST \
+ --disable-shared \
+ --enable-static
+
+make
+make install-strip
+cd -
+
+PKG_CONFIG_PATH="$LIBINST/lib/pkgconfig:$PKG_CONFIG_PATH" \
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-static \
+ --build=$ARCH-slackware-linux
+
+make
+make install-strip DESTDIR=$PKG docdir=$DOCDIR
+
+# who ever heard of man section "l"? horrible idea anyway (looks too
+# much like a 1 in most fonts). the "right" way to fix this would
+# be to sed docs/Makefile.am, but this project is too old for modern
+# autotools to work with, so post hoc hackery is called for. While
+# we're at it, fix some grammar and readability issues.
+mkdir -p $PKG/usr/man/man1
+mv $PKG/usr/man/manl/$PRGNAM.l $PKG/usr/man/man1/$PRGNAM.1
+rm -rf $PKG/usr/man/manl
+sed -i -e "s,\($PRGNAM \)l,\11,g" \
+ -e 's/Command (/Commands (/' \
+ -e 's/may also/will also/' \
+ -e 's/writes it to/writes (pipes) it to/' \
+ -e 's/which will be passed the/will be passed \\fBfountain\\fR'"'s standard/" \
+ -e 's/quoted from the shell/quoted to protect them from the shell/' \
+ $PKG/usr/man/man1/$PRGNAM.1
+gzip -9 $PKG/usr/man/man1/$PRGNAM.1
+
+cp -a COPYING ChangeLog NEWS README $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/fountain/fountain.info b/system/fountain/fountain.info
new file mode 100644
index 0000000000..61411cbb48
--- /dev/null
+++ b/system/fountain/fountain.info
@@ -0,0 +1,12 @@
+PRGNAM="fountain"
+VERSION="1.0.3"
+HOMEPAGE="https://asc.harvard.edu/cal/Downloads/Hrma/software/src/fountain/"
+DOWNLOAD="https://asc.harvard.edu/cal/Downloads/Hrma/software/src/fountain/fountain-1.0.3.tar.gz \
+ https://asc.harvard.edu/cal/Downloads/Hrma/software/src/tracefct/tracefct-1.0.10.tar.gz"
+MD5SUM="5d30969de692fa1a480ba25c73f89ae4 \
+ d6ba9f17f28b4e1a95e4c20f775bb1e4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/system/fountain/slack-desc b/system/fountain/slack-desc
new file mode 100644
index 0000000000..9c69e68495
--- /dev/null
+++ b/system/fountain/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+fountain: fountain (pipe standard input to multiple processes)
+fountain:
+fountain: Fountain take a single input stream and write it to multiple output
+fountain: streams. This is similar to tee(1), except tee writes data to files;
+fountain: fountain runs commands and pipes data to them.
+fountain:
+fountain:
+fountain:
+fountain:
+fountain:
+fountain: