summaryrefslogtreecommitdiffstats
path: root/system/d-feet
diff options
context:
space:
mode:
author Robby Workman2010-08-22 17:34:33 +0200
committer Erik Hanson2010-08-23 07:53:39 +0200
commitd576c35e1b44dafa50095139ffb88eae7d614b45 (patch)
treefe3f4db5f4358dc3418521a260a42e7e232f6666 /system/d-feet
parent5a7fa9c6bf4665c6796c55a5db9dc6450537b2cf (diff)
downloadslackbuilds-d576c35e1b44dafa50095139ffb88eae7d614b45.tar.gz
system/d-feet: Added (D-Bus Debugger)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'system/d-feet')
-rw-r--r--system/d-feet/README3
-rw-r--r--system/d-feet/d-feet.SlackBuild74
-rw-r--r--system/d-feet/d-feet.info10
-rw-r--r--system/d-feet/doinst.sh10
-rw-r--r--system/d-feet/slack-desc19
5 files changed, 116 insertions, 0 deletions
diff --git a/system/d-feet/README b/system/d-feet/README
new file mode 100644
index 0000000000..97d2bde8cf
--- /dev/null
+++ b/system/d-feet/README
@@ -0,0 +1,3 @@
+D-Feet is a D-Bus debugger written in PyGtk by John (J5) Palmieri.
+
+This requires pysetuptools.
diff --git a/system/d-feet/d-feet.SlackBuild b/system/d-feet/d-feet.SlackBuild
new file mode 100644
index 0000000000..6d04d117f3
--- /dev/null
+++ b/system/d-feet/d-feet.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackware build script for d-feet
+
+# Copyright 2010 Robby Workman, Northport, Alabama, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=d-feet
+VERSION=0.1.10
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING PKG-INFO README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/d-feet/d-feet.info b/system/d-feet/d-feet.info
new file mode 100644
index 0000000000..85dc980c46
--- /dev/null
+++ b/system/d-feet/d-feet.info
@@ -0,0 +1,10 @@
+PRGNAM="d-feet"
+VERSION="0.1.10"
+HOMEPAGE="https://fedorahosted.org/d-feet/"
+DOWNLOAD="http://johnp.fedorapeople.org/downloads/d-feet/d-feet-0.1.10.tar.bz2"
+MD5SUM="5617f8420f31a7b44d747d7760be4b62"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Robby Workman"
+EMAIL="rw@rlworkman.net"
+APPROVED="dsomero"
diff --git a/system/d-feet/doinst.sh b/system/d-feet/doinst.sh
new file mode 100644
index 0000000000..1f8ff67ded
--- /dev/null
+++ b/system/d-feet/doinst.sh
@@ -0,0 +1,10 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
diff --git a/system/d-feet/slack-desc b/system/d-feet/slack-desc
new file mode 100644
index 0000000000..961ec32a79
--- /dev/null
+++ b/system/d-feet/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-------------------------------------------------------|
+d-feet: D-Feet (D-Bus Debugger)
+d-feet:
+d-feet: D-Feet is a D-Bus debugger written in PyGtk by John (J5) Palmieri.
+d-feet:
+d-feet: Current features include:
+d-feet: - View names on any bus
+d-feet: - View exported objects, interfaces, methods and signals
+d-feet: - View the full command line of services on the bus
+d-feet: - Execute methods with parameters on the bus and see the return values
+d-feet:
+d-feet: