summaryrefslogtreecommitdiffstats
path: root/system/bit-babbler/bit-babbler.SlackBuild
diff options
context:
space:
mode:
author awg2018-07-18 23:09:32 +0200
committer Willy Sudiarto Raharjo2018-07-21 01:53:30 +0200
commit3f8323881180a1172fa998a9d66b4e6d5582183a (patch)
treeca4e1734a08d7032c4ebc07a2d6bc2f9f19b55b6 /system/bit-babbler/bit-babbler.SlackBuild
parent6c17771f3157e0b63e5176145ea39b6b69e96acc (diff)
downloadslackbuilds-3f8323881180a1172fa998a9d66b4e6d5582183a.tar.gz
system/bit-babbler: Updated for version 0.8.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system/bit-babbler/bit-babbler.SlackBuild')
-rw-r--r--system/bit-babbler/bit-babbler.SlackBuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/system/bit-babbler/bit-babbler.SlackBuild b/system/bit-babbler/bit-babbler.SlackBuild
index 5e7051b91d..6661ad3409 100644
--- a/system/bit-babbler/bit-babbler.SlackBuild
+++ b/system/bit-babbler/bit-babbler.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
-# SlackBuild for bit-babbler, 24 September 2017
-# AW Green <awg@posteo.us>
+# SlackBuild for bit-babbler, 5 March 2018
+# awg <awg@cock.li>
# All rights reserved.
#
# Permission to use, copy, modify, or distribute this software for any
@@ -21,7 +21,7 @@
## see the file 'copyright' in the bit-babbler source distribution.
PRGNAM=bit-babbler
-VERSION=${VERSION:-0.7}
+VERSION=${VERSION:-0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -88,7 +88,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a debian/copyright debian/changelog doc/virtual_machines $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/copyright debian/changelog debian/bit-babbler.NEWS doc/virtual_machines $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
# install sysctl setting, udev rules, and init script.
@@ -96,6 +96,9 @@ install -D -m 0644 debian/bit-babbler-sysctl.conf $PKG/etc/sysctl.d/bit-babbler-
install -D -m 0644 debian/bit-babbler.udev $PKG/lib/udev/rules.d/90-bit-babbler.rules
install -D -m 0644 $CWD/rc.seedd.new $PKG/etc/rc.d/rc.seedd.new
+# cut out unneeded files.
+rm -rv $PKG/lib/systemd/
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh