summaryrefslogtreecommitdiffstats
path: root/system/autoarchive
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-21 16:56:32 +0100
committer Erik Hanson2014-01-30 06:21:09 +0100
commita4e2b5a930f57ad1980bde4b443d50cf7d4b8f2c (patch)
tree91f8468befdc4f11bc98f17e26442c23bd6b40fc /system/autoarchive
parent8eb69e64be754c60ca3b85a6721a3d711af3a272 (diff)
downloadslackbuilds-a4e2b5a930f57ad1980bde4b443d50cf7d4b8f2c.tar.gz
system/autoarchive: Added (A simple backup utility).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/autoarchive')
-rw-r--r--system/autoarchive/README14
-rw-r--r--system/autoarchive/autoarchive.SlackBuild95
-rw-r--r--system/autoarchive/autoarchive.info10
-rw-r--r--system/autoarchive/doinst.sh15
-rw-r--r--system/autoarchive/slack-desc19
5 files changed, 153 insertions, 0 deletions
diff --git a/system/autoarchive/README b/system/autoarchive/README
new file mode 100644
index 0000000000..20fe2157be
--- /dev/null
+++ b/system/autoarchive/README
@@ -0,0 +1,14 @@
+AutoArchive is a simple utility to help create backups more
+easily. The idea of the program is that all essential information for
+creating a single backup---such as list of directories that should be
+archived, the archive name, etc.---is stored in a single file -- the
+*archive specification file*. It can use 'tar' for creating archives,
+it has a command line interface and supports incremental backups.
+
+Archive specification files, also called ".aa files" are normally
+stored in a predefined location from where they are processed by the
+"aa" command which results to creating of a corresponding *backup* for
+each.
+
+Command "autoarchive" is alias for "aa"; these commands are
+equivalent.
diff --git a/system/autoarchive/autoarchive.SlackBuild b/system/autoarchive/autoarchive.SlackBuild
new file mode 100644
index 0000000000..2e20001c99
--- /dev/null
+++ b/system/autoarchive/autoarchive.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# Slackware build script for autoarchive
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=autoarchive
+VERSION=${VERSION:-1.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr
+find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/etc/aa/aa.conf $PKG/etc/aa/aa.conf.new
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README COPYING NEWS PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mv $PKG/usr/share/doc/$PRGNAM-$VERSION/examples/ $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/share/doc/$PRGNAM-$VERSION/html/ $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share/
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/autoarchive/autoarchive.info b/system/autoarchive/autoarchive.info
new file mode 100644
index 0000000000..ab4c571926
--- /dev/null
+++ b/system/autoarchive/autoarchive.info
@@ -0,0 +1,10 @@
+PRGNAM="autoarchive"
+VERSION="1.0.1"
+HOMEPAGE="http://autoarchive.sourceforge.net/"
+DOWNLOAD="http://sourceforge.net/projects/autoarchive/files/autoarchive/1.0.1/autoarchive-1.0.1.tar.bz2"
+MD5SUM="527aec9ec5357db6bd088267ece0e283"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/system/autoarchive/doinst.sh b/system/autoarchive/doinst.sh
new file mode 100644
index 0000000000..13f58a01e8
--- /dev/null
+++ b/system/autoarchive/doinst.sh
@@ -0,0 +1,15 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ rm $NEW
+ fi
+}
+
+config /etc/aa/aa.conf.new
+
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/system/autoarchive/slack-desc b/system/autoarchive/slack-desc
new file mode 100644
index 0000000000..6e96c9e9b7
--- /dev/null
+++ b/system/autoarchive/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+autoarchive: autoarchive (A simple backup utility)
+autoarchive:
+autoarchive: AutoArchive is a simple utility to help create backups more easily.
+autoarchive: The idea of the program is that all essential information for
+autoarchive: creating a single backup---such as list of directories that should be
+autoarchive: archived, the archive name, etc.---is stored in a single file -- the
+autoarchive: archive specification file. It can use ‘tar’ for creating archives,
+autoarchive: it has a command line interface and supports incremental backups.
+autoarchive:
+autoarchive: Homepage: http://autoarchive.sourceforge.net
+autoarchive: