summaryrefslogtreecommitdiffstats
path: root/system/apachetop
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2016-01-24 01:27:32 +0100
committer Willy Sudiarto Raharjo2016-01-25 01:25:07 +0100
commit1ceb24dc5e7428bf3a98f2346935bac3efcaa79d (patch)
tree3289384e3a91272c13171c750e6f3ac020aac5f5 /system/apachetop
parent8e2a719822e2abfc020eeaa3af2e179b76fe5835 (diff)
downloadslackbuilds-1ceb24dc5e7428bf3a98f2346935bac3efcaa79d.tar.gz
system/apachetop: Updated for version 0.15.6.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/apachetop')
-rw-r--r--system/apachetop/apachetop-0.12.6-maxpathlen.patch39
-rw-r--r--system/apachetop/apachetop.SlackBuild24
-rw-r--r--system/apachetop/apachetop.info6
3 files changed, 12 insertions, 57 deletions
diff --git a/system/apachetop/apachetop-0.12.6-maxpathlen.patch b/system/apachetop/apachetop-0.12.6-maxpathlen.patch
deleted file mode 100644
index 3b320d23d0..0000000000
--- a/system/apachetop/apachetop-0.12.6-maxpathlen.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Patch by Robert Scheck <robert@fedoraproject.org> for apachetop <= 0.12.6, which
-adds some includes in order to have a real change to get MAXPATHLEN defined with
-a valid value. Once MAXPATHLEN really gets filled with 128, it will just cause a
-buffer overflow.
-
-See Red Hat Bugzilla #446199 (https://bugzilla.redhat.com/show_bug.cgi?id=446199)
-for more information. This patch should solve the mentioned bug report and should
-be sane enough to get included by upstream of apachetop for the next release. It
-is important to run autoheader before ./configure to get these changes activated.
-
---- apachetop-0.12.6/configure.ac.orig 2005-10-27 18:39:25.000000000 +0200
-+++ apachetop-0.12.6/configure.ac 2008-06-21 16:00:38.000000000 +0200
-@@ -34,7 +34,8 @@
- # Checks for header files.
- AC_HEADER_STDC
- AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h \
-- string.h strings.h sys/socket.h time.h sys/time.h])
-+ string.h strings.h sys/socket.h time.h sys/time.h \
-+ limits.h sys/param.h])
-
- # Checks for typedefs, structures, and compiler characteristics.
- #AC_HEADER_STDBOOL # not in 2.53?
---- apachetop-0.12.6/src/apachetop.h.orig 2005-10-15 18:10:01.000000000 +0200
-+++ apachetop-0.12.6/src/apachetop.h 2008-06-21 16:02:00.000000000 +0200
-@@ -89,8 +89,12 @@
- #define getMIN(a,b) (a < b ? a : b)
- #define getMAX(a,b) (a > b ? a : b)
-
--#ifndef MAXPATHLEN
--# define MAXPATHLEN 128
-+#ifdef HAVE_SYS_PARAM_H
-+# include <sys/param.h>
-+#endif
-+
-+#if HAVE_LIMITS_H
-+# include <limits.h>
- #endif
-
- /* upon startup, each input file is put into an element of this array,
diff --git a/system/apachetop/apachetop.SlackBuild b/system/apachetop/apachetop.SlackBuild
index 9dcfd7b091..e7a3a26f91 100644
--- a/system/apachetop/apachetop.SlackBuild
+++ b/system/apachetop/apachetop.SlackBuild
@@ -10,8 +10,8 @@
# See http://sam.zoy.org/wtfpl/COPYING for more details.
PRGNAM=apachetop
-VERSION=${VERSION:-0.12.6}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.15.6}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -51,10 +51,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Apply a patch by Aaron McClimont to allow writing statistics to a file.
# For like MRTG to use (or Cricket, Cacti, Torrus, whatever).
@@ -63,9 +63,6 @@ patch -p0 < $CWD/apachetop.outputfile.patch
# Add mension of the feature added above to the manpage.
patch -p0 < $CWD/apachetop.manpage.diff
-# Add patch from Fedora Project to fix buffer overflow possibility
-patch -p1 < $CWD/apachetop-0.12.6-maxpathlen.patch
-
# Add --with-adns=<path> if you have adns installed and want ApacheTop support
# Note: The log to parce can be overwritten at runtime, using the '-f' flag.
CXXFLAGS="$SLKCFLAGS" \
@@ -80,18 +77,15 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-find $PKG -type f | xargs file | grep -e "executable" -e "shared object" \
- | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man || exit 1
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a [A-Z][A-Z][A-Z]* ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.$TAG
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/system/apachetop/apachetop.info b/system/apachetop/apachetop.info
index b16950f612..879151c5cc 100644
--- a/system/apachetop/apachetop.info
+++ b/system/apachetop/apachetop.info
@@ -1,8 +1,8 @@
PRGNAM="apachetop"
-VERSION="0.12.6"
+VERSION="0.15.6"
HOMEPAGE="http://freecode.com/projects/apachetop"
-DOWNLOAD="http://pkgs.fedoraproject.org/repo/pkgs/apachetop/apachetop-0.12.6.tar.gz/604283ac4bbbddd98fc9b1f11381657e/apachetop-0.12.6.tar.gz"
-MD5SUM="604283ac4bbbddd98fc9b1f11381657e"
+DOWNLOAD="http://pkgs.fedoraproject.org/repo/pkgs/apachetop/apachetop-0.15.6.tar.gz/69896c163abd3fd1961f5939fbe6c4cf/apachetop-0.15.6.tar.gz"
+MD5SUM="69896c163abd3fd1961f5939fbe6c4cf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""