summaryrefslogtreecommitdiffstats
path: root/system/ansible/ansible.SlackBuild
diff options
context:
space:
mode:
author Alex Diaconu2014-10-30 04:15:00 +0100
committer Willy Sudiarto Raharjo2014-10-30 14:27:36 +0100
commitaa4e553cdd33f55e9b563fef8d032e5c359a14fc (patch)
tree8f2b8528269fa1df1c656f4e4882c3d553f44e57 /system/ansible/ansible.SlackBuild
parent360f749b9af70dbdafe9ceaafd444ea2e3d89ce4 (diff)
downloadslackbuilds-aa4e553cdd33f55e9b563fef8d032e5c359a14fc.tar.gz
system/ansible: Updated for version 1.7.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/ansible/ansible.SlackBuild')
-rw-r--r--system/ansible/ansible.SlackBuild41
1 files changed, 15 insertions, 26 deletions
diff --git a/system/ansible/ansible.SlackBuild b/system/ansible/ansible.SlackBuild
index 3d10271527..c4cd7a65d2 100644
--- a/system/ansible/ansible.SlackBuild
+++ b/system/ansible/ansible.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ansible
-# Copyright 2013 Alex Diaconu <alex.diaconu@gmx.com>
+# Copyright 2014 Alex Diaconu <alex.diaconu@gmx.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ansible
-VERSION=${VERSION:-1.2.1}
+VERSION=${VERSION:-1.7.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -67,44 +67,33 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/Makefile.patch
+python setup.py install --root=$PKG
-make docs
-python setup.py install $SLKFLAGS --root=$PKG
-
-# Copy and compress manpages
+# We don't need these, do we?
rm -r docs/man/man1/*asciidoc.in
+
+# Copy docs, remove git traces, compress manpages
cp -a docs/man $PKG/usr/man
+find $PKG/usr/man \
+ \( -iname '.git*' \
+ -o -iname 'man3' \) -delete # "man3" contains a single ".gitdir" file (yeah)
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-# Remove git remnants
-find $PKG/usr/man -iname '.git*' -delete
-
-# Remove redundant executable perms granted to some modules
+# 15 files (modules) out of 248 have their executable bit activated, while none
+# of them seems to require it. The command that follows simply assumes that
+# those files escaped upstream scrutiny and simply removes the executable
+# permissions.
find $PKG/usr/share/ansible -type f -perm /111 -exec chmod -x {} \;
-# Fix plugin paths and also remove the duplicated 'library' and 'hostfile' settings
-orig_path="/usr/share/ansible_plugins"
-site_packages="$(python2 -c 'from distutils.sysconfig import get_python_lib; print get_python_lib();')/ansible"
-plug_pat='(action|filter|connection|lookup)'
-sed -i -r \
- -e "s:$orig_path/${plug_pat}_plugins:$site_packages/runner/\1_plugins:" \
- -e "s:$orig_path/callback_plugins:$site_packages/callback_plugins:" \
- -e "s:$orig_path/vars_plugins:$site_packages/inventory/vars_plugins:" \
- -e "7,12d" \
- examples/ansible.cfg
-
mkdir -p $PKG/etc/ansible
cp -a examples/ansible.cfg $PKG/etc/ansible/ansible.cfg.new
cp -a examples/hosts $PKG/etc/ansible/hosts.new
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- examples COPYING RELEASES.txt *.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a examples COPYING *.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install