summaryrefslogtreecommitdiffstats
path: root/system/Solaar
diff options
context:
space:
mode:
author Erich Ritz2019-12-19 16:58:20 +0100
committer Willy Sudiarto Raharjo2019-12-19 16:58:20 +0100
commit61d9c5d72714f5bfe1c3bdcb5778355273ec231e (patch)
tree3dab0bc30f1f12ad983821928e055802b9eab126 /system/Solaar
parent7e124537fd886c14f022c0bd50f2082736f376b7 (diff)
downloadslackbuilds-61d9c5d72714f5bfe1c3bdcb5778355273ec231e.tar.gz
system/Solaar: Added (Linux device manager for Logitech).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/Solaar')
-rw-r--r--system/Solaar/README23
-rw-r--r--system/Solaar/Solaar.SlackBuild78
-rw-r--r--system/Solaar/Solaar.info10
-rw-r--r--system/Solaar/doinst.sh9
-rw-r--r--system/Solaar/slack-desc12
5 files changed, 132 insertions, 0 deletions
diff --git a/system/Solaar/README b/system/Solaar/README
new file mode 100644
index 0000000000..9c6b8509f9
--- /dev/null
+++ b/system/Solaar/README
@@ -0,0 +1,23 @@
+Solaar is a Linux device manager for Logitech's Unifying Receiver
+peripherals. It is able to pair/unpair devices to the receiver, and for
+most devices read battery status.
+
+It comes in two flavors, command-line and GUI. Both are able to list the
+devices paired to a Unifying Receiver, show detailed info for each
+device, and also pair/unpair supported devices with the receiver.
+
+Solaar will detect all devices paired with your Unifying Receiver, and
+at the very least display some basic information about them. For some
+devices, extra settings (usually not available through the standard
+Linux system configuration) are supported.
+
+By default, the udev rule
+/etc/udev/rules.d/42-logitech-unifying-receiver.rules
+allows all members of the plugdev group to have read/write access to the
+Unifying Receiver device. Therefore, make sure all desktop users are
+part of the plugdev group:
+usermod -a -G plugdev <username>
+
+After installation, you must physically remove the Unifying Receiver and
+re-insert it for the device node permissions to take effect for the
+first time.
diff --git a/system/Solaar/Solaar.SlackBuild b/system/Solaar/Solaar.SlackBuild
new file mode 100644
index 0000000000..360cf018f8
--- /dev/null
+++ b/system/Solaar/Solaar.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# Slackware build script for Solaar
+
+# Copyright 2019 Erich Ritz, Scottsdale, Arizona, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Solaar
+VERSION=${VERSION:-1.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+if [ -e $CWD/$VERSION.tar.gz ]; then
+ tar xvf $CWD/$VERSION.tar.gz
+else
+ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+fi
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/etc/udev/rules.d
+cp -a rules.d/42-logitech-unify-permissions.rules $PKG/etc/udev/rules.d
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING COPYRIGHT ChangeLog README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/Solaar/Solaar.info b/system/Solaar/Solaar.info
new file mode 100644
index 0000000000..dc37e41ca4
--- /dev/null
+++ b/system/Solaar/Solaar.info
@@ -0,0 +1,10 @@
+PRGNAM="Solaar"
+VERSION="1.0.1"
+HOMEPAGE="https://pwr-solaar.github.io/Solaar/"
+DOWNLOAD="https://github.com/pwr-Solaar/Solaar/archive/1.0.1/Solaar-1.0.1.tar.gz"
+MD5SUM="1464f68e000b2f93897ccc5736bfb61a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyudev"
+MAINTAINER="Erich Ritz"
+EMAIL="erich.public@protonmail.com"
diff --git a/system/Solaar/doinst.sh b/system/Solaar/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/system/Solaar/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/system/Solaar/slack-desc b/system/Solaar/slack-desc
new file mode 100644
index 0000000000..65f03aa025
--- /dev/null
+++ b/system/Solaar/slack-desc
@@ -0,0 +1,12 @@
+ |-----handy-ruler------------------------------------------------------|
+Solaar: Solaar (Linux device manager for Logitech's Unifying Receiver periphs)
+Solaar:
+Solaar: Solaar is a Linux device manager for Logitech's Unifying Receiver
+Solaar: peripherals. It is able to pair/unpair devices to the receiver, and
+Solaar: for most devices read battery status.
+Solaar:
+Solaar: It comes in two flavors, command-line and GUI. Both are able to list
+Solaar: the devices paired to a Unifying Receiver, show detailed info for each
+Solaar: device, and alos pair/unpair supported devices with the receiver.
+Solaar:
+Solaar: Homepage: https://pwr-solaar.github.io/Solaar/