summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2024-05-12 19:06:45 +0200
committer Willy Sudiarto Raharjo2024-05-18 01:55:35 +0200
commita520ad01fe403dc75e302321a97b0ed7c2a91570 (patch)
treed40b361dab8fb760a8e3a9f494d3c10e4278282c /python
parent3a8b3d757dff6282b4e8c8bc539d8a6f31e96805 (diff)
downloadslackbuilds-a520ad01fe403dc75e302321a97b0ed7c2a91570.tar.gz
python/gunicorn: Updated for version 22.0.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/gunicorn/gunicorn.SlackBuild10
-rw-r--r--python/gunicorn/gunicorn.info10
2 files changed, 12 insertions, 8 deletions
diff --git a/python/gunicorn/gunicorn.SlackBuild b/python/gunicorn/gunicorn.SlackBuild
index 3aff3a8ea5..46db2aef69 100644
--- a/python/gunicorn/gunicorn.SlackBuild
+++ b/python/gunicorn/gunicorn.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gunicorn
-# Copyright 2016-2022 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gunicorn
-VERSION=${VERSION:-20.1.0}
+VERSION=${VERSION:-22.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,7 +79,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/gunicorn/gunicorn.info b/python/gunicorn/gunicorn.info
index adaf475a12..d8f62aee72 100644
--- a/python/gunicorn/gunicorn.info
+++ b/python/gunicorn/gunicorn.info
@@ -1,10 +1,10 @@
PRGNAM="gunicorn"
-VERSION="20.1.0"
+VERSION="22.0.0"
HOMEPAGE="https://gunicorn.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/28/5b/0d1f0296485a6af03366604142ea8f19f0833894db3512a40ed07b2a56dd/gunicorn-20.1.0.tar.gz"
-MD5SUM="db8a7c5c2064000af70286534803bf1d"
+DOWNLOAD="https://files.pythonhosted.org/packages/1e/88/e2f93c5738a4c1f56a458fc7a5b1676fc31dcdbb182bef6b40a141c17d66/gunicorn-22.0.0.tar.gz"
+MD5SUM="c02e8493f941ebeddad35788f427aba2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"