summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2024-05-15 18:31:58 +0200
committer Willy Sudiarto Raharjo2024-05-18 01:55:42 +0200
commit71388ef5c6ce6c6638f2ee48ad42eb76467ad049 (patch)
tree0f072fbc4c1985df88cb8eb8854510385a4ccc53 /python
parent0c749ce89fb23c1e615705ce496f3f5ed67352dd (diff)
downloadslackbuilds-71388ef5c6ce6c6638f2ee48ad42eb76467ad049.tar.gz
python/pillowfight: Removed unused.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pillowfight/README15
-rw-r--r--python/pillowfight/pillowfight.SlackBuild95
-rw-r--r--python/pillowfight/pillowfight.info10
-rw-r--r--python/pillowfight/slack-desc19
4 files changed, 0 insertions, 139 deletions
diff --git a/python/pillowfight/README b/python/pillowfight/README
deleted file mode 100644
index 598342a8c8..0000000000
--- a/python/pillowfight/README
+++ /dev/null
@@ -1,15 +0,0 @@
-Pillow is a replacement for PIL that works as a drop-in replacement.
-Unlike PIL, it's actively maintained and easy to install. It's pretty
-great. There's only one problem, which is that users must first
-uninstall PIL before installing Pillow, as they share a namespace.
-
-This makes it very hard for Python modules or products that need to
-run on a variety of configurations to easily depend on either PIL
-or Pillow without inevitably breaking something (perhaps in subtle
-ways). That makes it hard to safely transition.
-
-This package aims to "solve" that by providing a single dependency
-that can intelligently depend on either PIL or Pillow, based on what's
-already on the system. Packages that still need to work if PIL is
-installed, but aim to transition to Pillow, can simply depend on the
-pillowfight package.
diff --git a/python/pillowfight/pillowfight.SlackBuild b/python/pillowfight/pillowfight.SlackBuild
deleted file mode 100644
index 4707e9f47b..0000000000
--- a/python/pillowfight/pillowfight.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pillowfight
-
-# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pillowfight
-VERSION=${VERSION:-0.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pillowfight/pillowfight.info b/python/pillowfight/pillowfight.info
deleted file mode 100644
index ad5d3e472d..0000000000
--- a/python/pillowfight/pillowfight.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pillowfight"
-VERSION="0.2"
-HOMEPAGE="https://github.com/beanbaginc/pillowfight"
-DOWNLOAD="https://pypi.python.org/packages/69/a3/47d229ad4a1fa90dc550ffee9f400e71c902e879780dbf77f8ab032d9d33/pillowfight-0.2.tar.gz"
-MD5SUM="5f5df64de2e2bf7599460da08dfca08d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/pillowfight/slack-desc b/python/pillowfight/slack-desc
deleted file mode 100644
index ba2fce6d50..0000000000
--- a/python/pillowfight/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pillowfight: pillowfight (transition from PIL to Pillow)
-pillowfight:
-pillowfight: Pillow is a replacement for PIL that works as a drop-in replacement.
-pillowfight: Unlike PIL, it's actively maintained and easy to install. It's
-pillowfight: pretty great. There's only one problem, which is that users must
-pillowfight: first uninstall PIL before installing Pillow, as they share a
-pillowfight: namespace.
-pillowfight:
-pillowfight: Homepage: https://github.com/beanbaginc/pillowfight
-pillowfight:
-pillowfight: