summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Vijay Marcel2024-05-17 03:09:50 +0200
committer Willy Sudiarto Raharjo2024-05-17 18:12:14 +0200
commit283980f9be6f5982e510db70baf692fd2af5032c (patch)
treee0ef37de36415a8318abc74f244cf69a7d7bcb05 /python
parentee6fbd0bb49454b667be55e5fed5eb3bfbd8994d (diff)
downloadslackbuilds-283980f9be6f5982e510db70baf692fd2af5032c.tar.gz
python/python3-aksharamukha: Updated for version 2.2.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-aksharamukha/README10
-rw-r--r--python/python3-aksharamukha/python3-aksharamukha.SlackBuild8
-rw-r--r--python/python3-aksharamukha/python3-aksharamukha.info6
3 files changed, 17 insertions, 7 deletions
diff --git a/python/python3-aksharamukha/README b/python/python3-aksharamukha/README
index 9bbd61968b..11a95b9de4 100644
--- a/python/python3-aksharamukha/README
+++ b/python/python3-aksharamukha/README
@@ -4,3 +4,13 @@ transliteration between the main Indian scripts along with sinhala.
Apart from simple mapping of characters it implements various script
language-specific conventions.Aksharamukha supports 120 scripts.
+Some scripts use diacritics to better represent the phonetics in
+english.To transliterate to other language from english Use the
+compose function in KDE for easier usage of diacritrics.
+you can enable it in systemsettings->Input Devices->Keyboard
+->Advanced->select configure keyboard option ->position of compose key.
+Then you can select which key you want to activate.
+
+For example if you enabled RightAlt key, to type á first press
+RightAlt key then type '+a you will automatically get á afterwards
+the compose key is released.
diff --git a/python/python3-aksharamukha/python3-aksharamukha.SlackBuild b/python/python3-aksharamukha/python3-aksharamukha.SlackBuild
index 66290962da..0bfd757fe5 100644
--- a/python/python3-aksharamukha/python3-aksharamukha.SlackBuild
+++ b/python/python3-aksharamukha/python3-aksharamukha.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-aksharamukha
-# Copyright 2023 Vijay Marcel
+# Copyright 2023-2024 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-aksharamukha
-VERSION=${VERSION:-2.1.2}
+VERSION=${VERSION:-2.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -84,10 +84,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ | cut -f 1 -d : | xargs strip --strip-unneeded --remove-section=.comment --remove-section=.note 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/python3-aksharamukha/python3-aksharamukha.info b/python/python3-aksharamukha/python3-aksharamukha.info
index 1af65368de..92e272cc8a 100644
--- a/python/python3-aksharamukha/python3-aksharamukha.info
+++ b/python/python3-aksharamukha/python3-aksharamukha.info
@@ -1,11 +1,11 @@
PRGNAM="python3-aksharamukha"
-VERSION="2.1.2"
+VERSION="2.2.2"
HOMEPAGE="https://github.com/virtualvinodh/aksharamukha-python"
-DOWNLOAD="https://pypi.io/packages/source/a/aksharamukha/aksharamukha-2.1.2.tar.gz \
+DOWNLOAD="https://pypi.io/packages/source/a/aksharamukha/aksharamukha-2.2.2.tar.gz \
https://www.gnu.org/licenses/agpl-3.0.txt \
https://www.gnu.org/licenses/gpl-3.0.txt \
https://github.com/lecramyajiv/akshara-doc/archive/1.0/akshara-doc-1.0.tar.gz"
-MD5SUM="4a272bc8daa35e0df603ab48dbe9d5b4 \
+MD5SUM="bb477c7d9181f4982fb8dc7f6635c3d6 \
eb1e647870add0502f8f010b19de32af \
1ebbd3e34237af26da5dc08a4e440464 \
1d287bc9c57a0b65489754c30917264d"