summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Jeremy Hansen2024-04-18 02:26:53 +0200
committer Willy Sudiarto Raharjo2024-04-19 16:40:49 +0200
commitba4d09cb1cfa7ec1cb15de93089b62c470f68486 (patch)
treeba63466d8d6c4673879abe93e7c0bf4b442346fa /python
parent565922cefc697c9a38c2b0080947931191aea2dc (diff)
downloadslackbuilds-ba4d09cb1cfa7ec1cb15de93089b62c470f68486.tar.gz
python/python3-matplotlib-inline: Version bump to 0.1.7
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-matplotlib-inline/python3-matplotlib-inline.SlackBuild23
-rw-r--r--python/python3-matplotlib-inline/python3-matplotlib-inline.info8
2 files changed, 23 insertions, 8 deletions
diff --git a/python/python3-matplotlib-inline/python3-matplotlib-inline.SlackBuild b/python/python3-matplotlib-inline/python3-matplotlib-inline.SlackBuild
index ecd88156d7..3b0561cd84 100644
--- a/python/python3-matplotlib-inline/python3-matplotlib-inline.SlackBuild
+++ b/python/python3-matplotlib-inline/python3-matplotlib-inline.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-matplotlib-inline
# Copyright 2021-2022 Isaac Yu <isaacyu@protonmail.com>
-# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-matplotlib-inline
-SRCNAM=matplotlib-inline
-VERSION=${VERSION:-0.1.6}
+SRCNAM=matplotlib_inline
+VERSION=${VERSION:-0.1.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -64,7 +64,22 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Fix version detection
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
+# Use newer python packages in /opt/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-matplotlib-inline/python3-matplotlib-inline.info b/python/python3-matplotlib-inline/python3-matplotlib-inline.info
index 5c2e373b8a..66b8129b3a 100644
--- a/python/python3-matplotlib-inline/python3-matplotlib-inline.info
+++ b/python/python3-matplotlib-inline/python3-matplotlib-inline.info
@@ -1,10 +1,10 @@
PRGNAM="python3-matplotlib-inline"
-VERSION="0.1.6"
+VERSION="0.1.7"
HOMEPAGE="https://github.com/ipython/matplotlib-inline"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/m/matplotlib-inline/matplotlib-inline-0.1.6.tar.gz"
-MD5SUM="aded9a57e2f526f76b3a4851d5528d4f"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/m/matplotlib-inline/matplotlib_inline-0.1.7.tar.gz"
+MD5SUM="96fe871bf30dc414e6724423c1e2ebb1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="traitlets"
+REQUIRES="traitlets python3-setuptools-opt python3-matplotlib"
MAINTAINER="Jeremy Hansen"
EMAIL="jebrhansen+SBo@gmail.com"