summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Giancarlo Dessì2022-04-02 05:33:35 +0200
committer Willy Sudiarto Raharjo2022-04-02 13:19:09 +0200
commit91320a9ad3599887d026623d3061f7437ea4608b (patch)
tree7f858dc5837041e5d2e8eb48c350e35175894c90 /python
parent0fc2276a1f053b9f5fd8581245993c09a68599ad (diff)
downloadslackbuilds-91320a9ad3599887d026623d3061f7437ea4608b.tar.gz
python/cloudpickle: Added (Python Module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/cloudpickle/README3
-rw-r--r--python/cloudpickle/cloudpickle.SlackBuild92
-rw-r--r--python/cloudpickle/cloudpickle.info10
-rw-r--r--python/cloudpickle/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/cloudpickle/README b/python/cloudpickle/README
new file mode 100644
index 0000000000..6feb3ec2d4
--- /dev/null
+++ b/python/cloudpickle/README
@@ -0,0 +1,3 @@
+cloudpickle is an extended pickling support for Python objects.
+It makes possible to serialize Python constructs not supported by
+the default pickle module from the Python standard library.
diff --git a/python/cloudpickle/cloudpickle.SlackBuild b/python/cloudpickle/cloudpickle.SlackBuild
new file mode 100644
index 0000000000..5b67c032cc
--- /dev/null
+++ b/python/cloudpickle/cloudpickle.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/bash
+
+# Slackware build script for cloudpickle
+
+# Copyright 2020-2022 Giancarlo Dessì, Cagliari, IT
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=cloudpickle
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO MANIFEST.in README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/cloudpickle/cloudpickle.info b/python/cloudpickle/cloudpickle.info
new file mode 100644
index 0000000000..01c071c4f2
--- /dev/null
+++ b/python/cloudpickle/cloudpickle.info
@@ -0,0 +1,10 @@
+PRGNAM="cloudpickle"
+VERSION="2.0.0"
+HOMEPAGE="https://pypi.org/project/cloudpickle/"
+DOWNLOAD="https://files.pythonhosted.org/packages/25/c4/29b4f944e8709c4cddfdb93f0278f57ba097ed46845d9bdf57178db31c64/cloudpickle-2.0.0.tar.gz"
+MD5SUM="133a7fe80b773937498918d0715b56bf"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Giancarlo Dessì"
+EMAIL="slack@giand.it"
diff --git a/python/cloudpickle/slack-desc b/python/cloudpickle/slack-desc
new file mode 100644
index 0000000000..7af91f9423
--- /dev/null
+++ b/python/cloudpickle/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cloudpickle: cloudpickle (Extended pickling support for Python objects)
+cloudpickle:
+cloudpickle: cloudpickle makes it possible to serialize Python constructs not
+cloudpickle: supported by the default pickle module from the Python
+cloudpickle: standard library. It is especially useful for cluster computing
+cloudpickle: where Python code is shipped over the network to execute on
+cloudpickle: remote hosts, possibly close to the data.
+cloudpickle:
+cloudpickle: Homepage: https://pypi.org/project/cloudpickle/
+cloudpickle:
+cloudpickle: