summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Arn02022-03-03 11:12:24 +0100
committer Andrew Clemons2022-03-04 12:21:35 +0100
commitf7574396e2ef825d4b74d7f4cc39c8e58fd6880a (patch)
treebdcfc37bd2b836e12c663fbdf9431d2059f81e16 /python
parent71411265e41735e394ef3d9ff412fdc82c11831d (diff)
downloadslackbuilds-f7574396e2ef825d4b74d7f4cc39c8e58fd6880a.tar.gz
python/python3-automat: cloned from Automat for python3, updated for version 20.2.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/python3-automat/README3
-rw-r--r--python/python3-automat/python3-automat.SlackBuild99
-rw-r--r--python/python3-automat/python3-automat.info10
-rw-r--r--python/python3-automat/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/python/python3-automat/README b/python/python3-automat/README
new file mode 100644
index 0000000000..44034e0b09
--- /dev/null
+++ b/python/python3-automat/README
@@ -0,0 +1,3 @@
+Automat is a library for concise, idiomatic Python expression of
+finite-state automata (particularly deterministic finite-state
+transducers).
diff --git a/python/python3-automat/python3-automat.SlackBuild b/python/python3-automat/python3-automat.SlackBuild
new file mode 100644
index 0000000000..853066e925
--- /dev/null
+++ b/python/python3-automat/python3-automat.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/bash
+
+# Slackware build script for python3 Automat
+#
+# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# Based on 14.2 python2 python/Automat slackbuild by:
+# Copyright 2017-2018 Markus Reichelt, Aachen, DE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-automat
+SRCNAM=Automat
+VERSION=${VERSION:-20.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar LICENSE README.* docs/ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-automat/python3-automat.info b/python/python3-automat/python3-automat.info
new file mode 100644
index 0000000000..0ca5ff83bc
--- /dev/null
+++ b/python/python3-automat/python3-automat.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-automat"
+VERSION="20.2.0"
+HOMEPAGE="https://pypi.python.org/pypi/Automat"
+DOWNLOAD="https://pypi.python.org/packages/source/A/Automat/Automat-20.2.0.tar.gz"
+MD5SUM="d6cef9886b037b8857bfbc686f3ae30a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-attrs python-m2r"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-automat/slack-desc b/python/python3-automat/slack-desc
new file mode 100644
index 0000000000..559d186a2c
--- /dev/null
+++ b/python/python3-automat/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-automat: Automat (Self-service finite-state machines)
+python3-automat:
+python3-automat: https://pypi.python.org/pypi/Automat
+python3-automat:
+python3-automat:
+python3-automat:
+python3-automat:
+python3-automat:
+python3-automat:
+python3-automat:
+python3-automat: