summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Arn02022-02-24 15:29:52 +0100
committer Willy Sudiarto Raharjo2022-02-24 16:11:41 +0100
commitf49cfa8d312061aeb182a4db2c8f7f432dfc7de1 (patch)
treea32670e8ff2ba79bbca24b51a45128804442e7c7 /python
parentc325377a99698366a42697899f19281312f60826 (diff)
downloadslackbuilds-f49cfa8d312061aeb182a4db2c8f7f432dfc7de1.tar.gz
python/python2-psycopg2: renamed from psycopg2 as the latest version supporting python2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python2-psycopg2/README5
-rw-r--r--python/python2-psycopg2/python2-psycopg2.SlackBuild87
-rw-r--r--python/python2-psycopg2/python2-psycopg2.info10
-rw-r--r--python/python2-psycopg2/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/python/python2-psycopg2/README b/python/python2-psycopg2/README
new file mode 100644
index 0000000000..1bf9af852f
--- /dev/null
+++ b/python/python2-psycopg2/README
@@ -0,0 +1,5 @@
+psycopg2 is a PostgreSQL database adapter for Python.
+It supports the full Python DBAPI 2.0, and is thread safe at level 2.
+psycopg2 was designed for heavily multi-threaded applications.
+
+This is the build for the python2 version of psycopg2
diff --git a/python/python2-psycopg2/python2-psycopg2.SlackBuild b/python/python2-psycopg2/python2-psycopg2.SlackBuild
new file mode 100644
index 0000000000..6a37f09fa8
--- /dev/null
+++ b/python/python2-psycopg2/python2-psycopg2.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/bash
+
+# Slackware build script for psycopg2 for python2
+
+# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# Copyright (c) 2018-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright (c) 2007 Daniel de Kok <moc.mikciat@leinad>
+# Copyright (c) 2010-2011, 2013 Carlos Corbacho <carlos@strangeworlds.co.uk>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-psycopg2
+SRCNAM=psycopg2
+VERSION=${VERSION:-2.8.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS INSTALL LICENSE NEWS README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-psycopg2/python2-psycopg2.info b/python/python2-psycopg2/python2-psycopg2.info
new file mode 100644
index 0000000000..8790a115e1
--- /dev/null
+++ b/python/python2-psycopg2/python2-psycopg2.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-psycopg2"
+VERSION="2.8.6"
+HOMEPAGE="http://initd.org/psycopg/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/psycopg2/psycopg2-2.8.6.tar.gz"
+MD5SUM="ae2ff92f1cfcd890bd5f09f4d1d7d60c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="postgresql"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python2-psycopg2/slack-desc b/python/python2-psycopg2/slack-desc
new file mode 100644
index 0000000000..7799fe9801
--- /dev/null
+++ b/python/python2-psycopg2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-psycopg2: python2-psycopg2 (Python2 PostgreSQL bindings)
+python2-psycopg2:
+python2-psycopg2: psycopg is a PostgreSQL database adapter for Python. It supports the
+python2-psycopg2: full Python DBAPI 2.0, and is thread safe at level 2. psycopg was
+python2-psycopg2: designed for heavily multi-threaded applications.
+python2-psycopg2:
+python2-psycopg2: The psycopg2 website can be found at:
+python2-psycopg2: http://initd.org/tracker/psycopg/wiki/PsycopgTwo
+python2-psycopg2:
+python2-psycopg2:
+python2-psycopg2: