summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Arn02022-03-03 11:12:26 +0100
committer Andrew Clemons2022-03-04 12:21:35 +0100
commitcc94bbb945382637dd9290b5808e35f188eb481f (patch)
treeef791a604a92bd90296ae1cbf06904ed07f692ec /python
parent8cc7b2d8785014e183d1cd415ea9990b87418481 (diff)
downloadslackbuilds-cc94bbb945382637dd9290b5808e35f188eb481f.tar.gz
python/python3-pyjwt: Updated for version 2.3.0, switch to python3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pyjwt/README3
-rw-r--r--python/python3-pyjwt/python3-pyjwt.SlackBuild85
-rw-r--r--python/python3-pyjwt/python3-pyjwt.info10
-rw-r--r--python/python3-pyjwt/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/python3-pyjwt/README b/python/python3-pyjwt/README
new file mode 100644
index 0000000000..21fcd9d904
--- /dev/null
+++ b/python/python3-pyjwt/README
@@ -0,0 +1,3 @@
+PyJWT is a Python library which allows you to encode and decode JSON Web
+Tokens (JWT). JWT is an open, industry-standard (RFC 7519) for representing
+claims securely between two parties.
diff --git a/python/python3-pyjwt/python3-pyjwt.SlackBuild b/python/python3-pyjwt/python3-pyjwt.SlackBuild
new file mode 100644
index 0000000000..7a66c248d0
--- /dev/null
+++ b/python/python3-pyjwt/python3-pyjwt.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/bash
+
+# Slackware build script for python3-pyjwt
+
+# Copyright 2022 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-pyjwt
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-2.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS* CHANGELOG* LICENSE* MANIFEST* README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pyjwt/python3-pyjwt.info b/python/python3-pyjwt/python3-pyjwt.info
new file mode 100644
index 0000000000..4c5efdbd01
--- /dev/null
+++ b/python/python3-pyjwt/python3-pyjwt.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pyjwt"
+VERSION="2.3.0"
+HOMEPAGE="https://github.com/jpadilla/pyjwt"
+DOWNLOAD="https://github.com/jpadilla/pyjwt/archive/2.3.0/pyjwt-2.3.0.tar.gz"
+MD5SUM="748876c7c6349f124a7c265f4cfd43ce"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-pyjwt/slack-desc b/python/python3-pyjwt/slack-desc
new file mode 100644
index 0000000000..16a6570a40
--- /dev/null
+++ b/python/python3-pyjwt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pyjwt: python-pyjwt (JSON Web Token implementation in Python)
+python3-pyjwt:
+python3-pyjwt: A Python implementation of RFC 7519.
+python3-pyjwt:
+python3-pyjwt:
+python3-pyjwt:
+python3-pyjwt:
+python3-pyjwt:
+python3-pyjwt:
+python3-pyjwt: Homepage: https://pyjwt.readthedocs.org
+python3-pyjwt: