summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Arn02022-03-02 10:44:05 +0100
committer Willy Sudiarto Raharjo2022-03-03 09:56:39 +0100
commitc5d809b1d5ef94f3b43fd5cdf0d25cb62fdc990c (patch)
treed1fdd3fdf1cff466bbdf00911a8a2645eb6b3d63 /python
parent07d9277718e454550ec2da7c5c8c4385b5820549 (diff)
downloadslackbuilds-c5d809b1d5ef94f3b43fd5cdf0d25cb62fdc990c.tar.gz
python/buildbot-worker: Updated for version 3.4.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/buildbot-slave/buildbot-slave.info10
-rw-r--r--python/buildbot-slave/slack-desc19
-rw-r--r--python/buildbot-worker/README (renamed from python/buildbot-slave/README)2
-rw-r--r--python/buildbot-worker/buildbot-worker.SlackBuild (renamed from python/buildbot-slave/buildbot-slave.SlackBuild)33
-rw-r--r--python/buildbot-worker/buildbot-worker.info10
-rw-r--r--python/buildbot-worker/slack-desc19
6 files changed, 42 insertions, 51 deletions
diff --git a/python/buildbot-slave/buildbot-slave.info b/python/buildbot-slave/buildbot-slave.info
deleted file mode 100644
index 3ec01c4496..0000000000
--- a/python/buildbot-slave/buildbot-slave.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="buildbot-slave"
-VERSION="0.8.12"
-HOMEPAGE="http://buildbot.net/"
-DOWNLOAD="https://pypi.python.org/packages/5a/3a/96a2d5d11d66dd7c70c74b6e82ef5cde3a564353d4adfff4b1418ed4df18/buildbot-slave-0.8.12.tar.gz"
-MD5SUM="a5bdda0174e0428b14580323d35b221f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-twisted"
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/buildbot-slave/slack-desc b/python/buildbot-slave/slack-desc
deleted file mode 100644
index 72f177b90d..0000000000
--- a/python/buildbot-slave/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-buildbot-slave: buildbot-slave (a slave to buildbot)
-buildbot-slave:
-buildbot-slave: buildbot-slave is a slave to the continuous integration system
-buildbot-slave: designed to automate the build/test cycle.
-buildbot-slave: By automatically rebuilding and testing the tree each time
-buildbot-slave: something has changed, build problems are pinpointed quickly,
-buildbot-slave: before other developers are inconvenienced by the failure.
-buildbot-slave:
-buildbot-slave: Homepage: http://buildbot.net
-buildbot-slave:
-buildbot-slave:
diff --git a/python/buildbot-slave/README b/python/buildbot-worker/README
index 265a1fcd93..4e209f21db 100644
--- a/python/buildbot-slave/README
+++ b/python/buildbot-worker/README
@@ -1,4 +1,4 @@
-Buildbot-slave is a slave to the continuous integration system
+Buildbot-worker is a worker to the continuous integration system
designed to automate the build/test cycle (buildbot).
By automatically rebuilding and testing the tree each time
something has changed, build problems are pinpointed quickly,
diff --git a/python/buildbot-slave/buildbot-slave.SlackBuild b/python/buildbot-worker/buildbot-worker.SlackBuild
index 71b211b9d9..ca796423f6 100644
--- a/python/buildbot-slave/buildbot-slave.SlackBuild
+++ b/python/buildbot-worker/buildbot-worker.SlackBuild
@@ -1,9 +1,8 @@
#!/bin/bash
-# Slackware build script for buildbot-slave
+# Slackware build script for python3 buildbot-worker
# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
-# Copyright 2012-2016 Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,13 +21,12 @@
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=buildbot-slave
-VERSION=${VERSION:-0.8.12}
+PRGNAM=buildbot-worker
+SRCNAM=${PRGNAM#python-*}
+VERSION=${VERSION:-3.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -72,32 +70,25 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION $PKG/usr/man/man1
-
-cp -a \
- COPYING NEWS README UPGRADING \
- $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/ COPYING NEWS PKG-INFO README UPGRADING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cp docs/buildslave.1 $PKG/usr/man/man1
-gzip -9 $PKG/usr/man/man1/buildslave.1
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/python/buildbot-worker/buildbot-worker.info b/python/buildbot-worker/buildbot-worker.info
new file mode 100644
index 0000000000..70fd49bdb3
--- /dev/null
+++ b/python/buildbot-worker/buildbot-worker.info
@@ -0,0 +1,10 @@
+PRGNAM="buildbot-worker"
+VERSION="3.4.1"
+HOMEPAGE="https://pypi.python.org/pypi/buildbot-worker"
+DOWNLOAD="https://pypi.python.org/packages/source/b/buildbot-worker/buildbot-worker-3.4.1.tar.gz"
+MD5SUM="d90ed3b580eed91fa2179a63cccda356"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-twisted"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/buildbot-worker/slack-desc b/python/buildbot-worker/slack-desc
new file mode 100644
index 0000000000..0545d27a69
--- /dev/null
+++ b/python/buildbot-worker/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+buildbot-worker: buildbot-worker (worker to buildbot)
+buildbot-worker:
+buildbot-worker: buildbot-woker is a slave to the continuous integration system
+buildbot-worker: designed to automate the build/test cycle.
+buildbot-worker: By automatically rebuilding and testing the tree each time
+buildbot-worker: something has changed, build problems are pinpointed quickly,
+buildbot-worker: before other developers are inconvenienced by the failure.
+buildbot-worker:
+buildbot-worker: Homepage: http://buildbot.net
+buildbot-worker:
+buildbot-worker: