summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Matteo Bernardini2022-02-16 18:57:54 +0100
committer Willy Sudiarto Raharjo2022-02-17 06:59:49 +0100
commitb8b4df85302e9691fb528970fda41b0085842762 (patch)
treeaed8b3783ed27eadecac4779ce6fb40bfe8c57d8 /python
parent2a2cb0157e2959917e306657b76ed82db81771fc (diff)
downloadslackbuilds-b8b4df85302e9691fb528970fda41b0085842762.tar.gz
python/traitlets: Removed (abandoned).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/traitlets/README12
-rw-r--r--python/traitlets/slack-desc19
-rw-r--r--python/traitlets/traitlets.SlackBuild97
-rw-r--r--python/traitlets/traitlets.info10
4 files changed, 0 insertions, 138 deletions
diff --git a/python/traitlets/README b/python/traitlets/README
deleted file mode 100644
index 67b73cc20d..0000000000
--- a/python/traitlets/README
+++ /dev/null
@@ -1,12 +0,0 @@
-Traitlets is a pure Python library enabling:
-
-* the enforcement of strong typing for attributes of Python objects (typed
- attributes are called "traits")
-* notifications on changes of trait attributes
-* automatic validation and coercion of trait attributes when attempting a
- change
-
-Its implementation relies on the descriptor pattern.
-
-Traitlets powers the configuration system of IPython and Jupyter and the
-declarative API of IPython interactive widgets.
diff --git a/python/traitlets/slack-desc b/python/traitlets/slack-desc
deleted file mode 100644
index 70648471ca..0000000000
--- a/python/traitlets/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-traitlets: traitlets (lightweight Traits-like module)
-traitlets:
-traitlets: Traitlets is a pure Python library enabling:
-traitlets: * the enforcement of strong typing for attributes of Python objects
-traitlets: * notifications on changes of trait attributes
-traitlets: * automatic validation and coercion of trait attributes when
-traitlets: attempting a change
-traitlets:
-traitlets:
-traitlets:
-traitlets:
diff --git a/python/traitlets/traitlets.SlackBuild b/python/traitlets/traitlets.SlackBuild
deleted file mode 100644
index b86ae294d7..0000000000
--- a/python/traitlets/traitlets.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for traitlets
-
-# Copyright 2017-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=traitlets
-VERSION=${VERSION:-5.0.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING.md README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/traitlets/traitlets.info b/python/traitlets/traitlets.info
deleted file mode 100644
index bca071c830..0000000000
--- a/python/traitlets/traitlets.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="traitlets"
-VERSION="5.0.5"
-HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://github.com/ipython/traitlets/archive/5.0.5/traitlets-5.0.5.tar.gz"
-MD5SUM="4c4b866f4b98082a2b60083ab9d6adf7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="ipython_genutils"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"