summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Arn02022-03-03 11:12:28 +0100
committer Andrew Clemons2022-03-04 12:21:35 +0100
commit8c40ac5ac582f916bf5b0df498dd43de3eb89b45 (patch)
tree0cffaf64e93d6751b5e058f934d32396e670697d /python
parentf7574396e2ef825d4b74d7f4cc39c8e58fd6880a (diff)
downloadslackbuilds-8c40ac5ac582f916bf5b0df498dd43de3eb89b45.tar.gz
python/python3-txaio: cloned from python2-txaio for python3,updated for version 22.2.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/python3-txaio/README4
-rw-r--r--python/python3-txaio/python3-txaio.SlackBuild96
-rw-r--r--python/python3-txaio/python3-txaio.info10
-rw-r--r--python/python3-txaio/slack-desc19
4 files changed, 129 insertions, 0 deletions
diff --git a/python/python3-txaio/README b/python/python3-txaio/README
new file mode 100644
index 0000000000..61b2a59c8c
--- /dev/null
+++ b/python/python3-txaio/README
@@ -0,0 +1,4 @@
+txaio is a helper library for writing code that runs unmodified on both
+Twisted and asyncio / Trollius. This is like six, but for wrapping
+over differences between Twisted and asyncio so one can write code that
+runs unmodified on both.
diff --git a/python/python3-txaio/python3-txaio.SlackBuild b/python/python3-txaio/python3-txaio.SlackBuild
new file mode 100644
index 0000000000..109c1fb5e3
--- /dev/null
+++ b/python/python3-txaio/python3-txaio.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for python3 txaio
+
+# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-txaio
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-22.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE* README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-txaio/python3-txaio.info b/python/python3-txaio/python3-txaio.info
new file mode 100644
index 0000000000..29e1fe2b24
--- /dev/null
+++ b/python/python3-txaio/python3-txaio.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-txaio"
+VERSION="22.2.1"
+HOMEPAGE="https://pypi.python.org/pypi/txaio"
+DOWNLOAD="https://pypi.python.org/packages/source/t/txaio/txaio-22.2.1.tar.gz"
+MD5SUM="9b692af4c4fce73cadd36374c138936b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-txaio/slack-desc b/python/python3-txaio/slack-desc
new file mode 100644
index 0000000000..1b9906dbef
--- /dev/null
+++ b/python/python3-txaio/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-txaio: python3-txaio (source code compatibility for Twisted/Trollius)
+python3-txaio:
+python3-txaio: txaio is a helper library for writing code that runs unmodified on
+python3-txaio: both Twisted and asyncio / Trollius.
+python3-txaio:
+python3-txaio: https://pypi.python.org/project/txaio
+python3-txaio:
+python3-txaio:
+python3-txaio:
+python3-txaio:
+python3-txaio: