summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Andrew Clemons2022-02-18 06:42:36 +0100
committer Willy Sudiarto Raharjo2022-02-19 06:10:41 +0100
commit88dabbc5f20eef814e633885171216c4691de663 (patch)
tree329fe38ba548690ddd52e9261b3d97432d858911 /python
parent015208478bf9a9e8cbd7a6d4cffb02c9283d2512 (diff)
downloadslackbuilds-88dabbc5f20eef814e633885171216c4691de663.tar.gz
python/python-fonttools: Updated for version 4.29.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-fonttools/README3
-rw-r--r--python/python-fonttools/python-fonttools.SlackBuild32
-rw-r--r--python/python-fonttools/python-fonttools.info8
3 files changed, 8 insertions, 35 deletions
diff --git a/python/python-fonttools/README b/python/python-fonttools/README
index a98212b443..6b4b084746 100644
--- a/python/python-fonttools/README
+++ b/python/python-fonttools/README
@@ -1,4 +1 @@
python-fonttools - A library to manipulate font files from Python.
-
-python-unicodedata2 is recommended otherwise fonttools will use the
-unicodedata included with the system python (which for python2 is quite old)
diff --git a/python/python-fonttools/python-fonttools.SlackBuild b/python/python-fonttools/python-fonttools.SlackBuild
index 2f09fd4833..d423458163 100644
--- a/python/python-fonttools/python-fonttools.SlackBuild
+++ b/python/python-fonttools/python-fonttools.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-fonttools
-# Copyright 2017-2019 Andrew Clemons, Wellington New Zealand
+# Copyright 2017-2019,2022 Andrew Clemons, Wellington New Zealand
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-fonttools
SRCNAM=fonttools
-VERSION=${VERSION:-3.44.0}
+VERSION=${VERSION:-4.29.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,31 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- BINARIES="fonttools pyftmerge pyftsubset ttx"
- # backup the python2 binaries
- for f in $BINARIES ; do
- mv "$PKG/usr/bin/$f"{,2}
- done
- mv $PKG/usr/share/man/man1/ttx{,2}.1
-
- python3 setup.py install --root=$PKG
-
- # rename the python3 binaries
- for f in $BINARIES ; do
- mv "$PKG/usr/bin/$f"{,3}
- done
- mv $PKG/usr/share/man/man1/ttx{,3}.1
-
- # restore the python2 binaries
- for f in $BINARIES ; do
- mv "$PKG/usr/bin/$f"{2,}
- done
- mv $PKG/usr/share/man/man1/ttx{2,}.1
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -117,7 +93,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE.* NEWS.rst README.rst \
+ CONTRIBUTING.md LICENSE.external README.rst CODE_OF_CONDUCT.md NEWS.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/python-fonttools/python-fonttools.info b/python/python-fonttools/python-fonttools.info
index 4812533ad2..71fbb4e54d 100644
--- a/python/python-fonttools/python-fonttools.info
+++ b/python/python-fonttools/python-fonttools.info
@@ -1,10 +1,10 @@
PRGNAM="python-fonttools"
-VERSION="3.44.0"
+VERSION="4.29.1"
HOMEPAGE="https://github.com/fonttools/fonttools"
-DOWNLOAD="https://github.com/fonttools/fonttools/archive/3.44.0/fonttools-3.44.0.tar.gz"
-MD5SUM="3f9ff311081a0f591a09552902671d29"
+DOWNLOAD="https://github.com/fonttools/fonttools/archive/4.29.1/fonttools-4.29.1.tar.gz"
+MD5SUM="dce124039f8c0f3c98c6c275eb846b8a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python-unicodedata2"
MAINTAINER="Andrew Clemons"
EMAIL="andrew.clemons@gmail.com"