summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Arn02022-03-03 11:12:27 +0100
committer Andrew Clemons2022-03-04 12:21:35 +0100
commit71411265e41735e394ef3d9ff412fdc82c11831d (patch)
tree2e29caca677ff67751a5cabe2c65ae59a0c0173e /python
parentcc94bbb945382637dd9290b5808e35f188eb481f (diff)
downloadslackbuilds-71411265e41735e394ef3d9ff412fdc82c11831d.tar.gz
python/python3-twisted: Updated for version 22.1.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/python3-twisted/README6
-rw-r--r--python/python3-twisted/python3-twisted.SlackBuild101
-rw-r--r--python/python3-twisted/python3-twisted.info10
-rw-r--r--python/python3-twisted/slack-desc19
4 files changed, 136 insertions, 0 deletions
diff --git a/python/python3-twisted/README b/python/python3-twisted/README
new file mode 100644
index 0000000000..b5ce41eb91
--- /dev/null
+++ b/python/python3-twisted/README
@@ -0,0 +1,6 @@
+Twisted is an event-driven networking engine written in Python and licensed
+under the MIT license.
+
+Twisted projects variously support TCP, UDP, SSL/TLS, multicast, Unix
+sockets, a large number of protocols (including HTTP, NNTP, IMAP, SSH,
+IRC, FTP, and others), and much more.
diff --git a/python/python3-twisted/python3-twisted.SlackBuild b/python/python3-twisted/python3-twisted.SlackBuild
new file mode 100644
index 0000000000..d027572f35
--- /dev/null
+++ b/python/python3-twisted/python3-twisted.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/bash
+
+# Slackware build script for python3-twisted
+
+# Copyright 2022 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Originally written by Marco Bonetti - Thanks!
+# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-twisted
+SRCNAM=Twisted
+VERSION=${VERSION:-22.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE* NEWS* README* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-twisted/python3-twisted.info b/python/python3-twisted/python3-twisted.info
new file mode 100644
index 0000000000..3ebe2428e9
--- /dev/null
+++ b/python/python3-twisted/python3-twisted.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-twisted"
+VERSION="22.1.0"
+HOMEPAGE="https://twistedmatrix.com/"
+DOWNLOAD="https://pypi.python.org/packages/source/T/Twisted/Twisted-22.1.0.tar.gz"
+MD5SUM="c818cb1ab241dc249517442e5a0e0412"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-automat constantly hyperlink incremental zope.interface"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-twisted/slack-desc b/python/python3-twisted/slack-desc
new file mode 100644
index 0000000000..d80d10eae7
--- /dev/null
+++ b/python/python3-twisted/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-twisted: python-twisted (Python networking engine)
+python3-twisted:
+python3-twisted: Twisted is an event-driven networking engine written in Python and
+python3-twisted: licensed under the MIT license.
+python3-twisted:
+python3-twisted: Homepage: https://twistedmatrix.com/
+python3-twisted:
+python3-twisted:
+python3-twisted:
+python3-twisted:
+python3-twisted: