summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Matteo Bernardini2022-02-16 19:08:05 +0100
committer Willy Sudiarto Raharjo2022-02-17 06:59:49 +0100
commit443a84e049ba00603fdbfc59492e08caecda4f47 (patch)
treebfb4edde43be8450bc5a921f7db3ab4272a97c3d /python
parentb8b4df85302e9691fb528970fda41b0085842762 (diff)
downloadslackbuilds-443a84e049ba00603fdbfc59492e08caecda4f47.tar.gz
python/python3-ipython-sql: Removed (no more ipython).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-ipython-sql/README3
-rw-r--r--python/python3-ipython-sql/python3-ipython-sql.SlackBuild92
-rw-r--r--python/python3-ipython-sql/python3-ipython-sql.info10
-rw-r--r--python/python3-ipython-sql/slack-desc19
4 files changed, 0 insertions, 124 deletions
diff --git a/python/python3-ipython-sql/README b/python/python3-ipython-sql/README
deleted file mode 100644
index ff4773763e..0000000000
--- a/python/python3-ipython-sql/README
+++ /dev/null
@@ -1,3 +0,0 @@
-ipython-sql provides SQL querying capabilities within IPython.
-
-This SlackBuild is supported only in Python3.
diff --git a/python/python3-ipython-sql/python3-ipython-sql.SlackBuild b/python/python3-ipython-sql/python3-ipython-sql.SlackBuild
deleted file mode 100644
index 881c638364..0000000000
--- a/python/python3-ipython-sql/python3-ipython-sql.SlackBuild
+++ /dev/null
@@ -1,92 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python3-ipython-sql
-
-# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-ipython-sql
-VERSION=${VERSION:-0.3.9}
-SRCNAM=ipython-sql
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-else
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE NEWS.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-ipython-sql/python3-ipython-sql.info b/python/python3-ipython-sql/python3-ipython-sql.info
deleted file mode 100644
index 23d9c0aa8d..0000000000
--- a/python/python3-ipython-sql/python3-ipython-sql.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-ipython-sql"
-VERSION="0.3.9"
-HOMEPAGE="https://pypi.python.org/pypi/ipython-sql"
-DOWNLOAD="https://files.pythonhosted.org/packages/83/ed/f6c8ece48f0f10a7543c971cdb1a62e6f91b374e31f6b579b7a37fb0a6a3/ipython-sql-0.3.9.tar.gz"
-MD5SUM="69407492ac7fcb92520e10d24b3b3194"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="ipython PrettyTable SQLAlchemy sqlparse"
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python3-ipython-sql/slack-desc b/python/python3-ipython-sql/slack-desc
deleted file mode 100644
index 815f552108..0000000000
--- a/python/python3-ipython-sql/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-ipython-sql: python3-ipython-sql (IPython extension)
-python3-ipython-sql:
-python3-ipython-sql: ipython-sql provides SQL querying capabilities within IPython.
-python3-ipython-sql:
-python3-ipython-sql:
-python3-ipython-sql:
-python3-ipython-sql:
-python3-ipython-sql:
-python3-ipython-sql:
-python3-ipython-sql:
-python3-ipython-sql: