summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Pouria Rezaei2022-01-17 16:20:07 +0100
committer Willy Sudiarto Raharjo2022-01-18 02:14:21 +0100
commite3b4641a3d9e466fdbefdfcad18f88fcfca5b389 (patch)
treeaf338a84a6585ff564765d64c92930ffd6f08654 /python
parent28a6ada9ebadab27a9c2aa1da2a528705d08794a (diff)
downloadslackbuilds-e3b4641a3d9e466fdbefdfcad18f88fcfca5b389.tar.gz
python/python3-fasteners: Updated for version 0.17.2.
New creepy packaging method with setup.cfg; I personally don't like it. Signed-off-by: Pouria Rezaei <Pouria.rz@outlook.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-fasteners/python3-fasteners.SlackBuild8
-rw-r--r--python/python3-fasteners/python3-fasteners.info6
2 files changed, 7 insertions, 7 deletions
diff --git a/python/python3-fasteners/python3-fasteners.SlackBuild b/python/python3-fasteners/python3-fasteners.SlackBuild
index 1c3b30a191..4bcf843685 100644
--- a/python/python3-fasteners/python3-fasteners.SlackBuild
+++ b/python/python3-fasteners/python3-fasteners.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-fasteners
-# Copyright 2019-2021 Pouria Rezaei <Pouria.rz@outlook.com>
+# Copyright 2019-2022 Pouria Rezaei <Pouria.rz@outlook.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-fasteners
-VERSION=${VERSION:-0.16.3}
+VERSION=${VERSION:-0.17.2}
SRCNAM=fasteners
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,10 +72,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -c 'from setuptools import setup; setup()' install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog LICENSE MANIFEST.in README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG LICENSE MANIFEST.in README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-fasteners/python3-fasteners.info b/python/python3-fasteners/python3-fasteners.info
index e74bc630b9..56d4d6879d 100644
--- a/python/python3-fasteners/python3-fasteners.info
+++ b/python/python3-fasteners/python3-fasteners.info
@@ -1,8 +1,8 @@
PRGNAM="python3-fasteners"
-VERSION="0.16.3"
+VERSION="0.17.2"
HOMEPAGE="https://github.com/harlowja/fasteners/"
-DOWNLOAD="https://files.pythonhosted.org/packages/28/e4/2888d41cdbd405828ccdb9a8536c5919939c2f4c6ab9b2ba63e9bd2570d5/fasteners-0.16.3.tar.gz"
-MD5SUM="243188fe770ad60e9da722bef9dc7a78"
+DOWNLOAD="https://files.pythonhosted.org/packages/cd/d0/16383819680f8a0c2fdb2aff98058e8653ed94426ecb07c4c18926207b1c/fasteners-0.17.2.tar.gz"
+MD5SUM="b01609ddea36c33cccf64299bdeb83d8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-monotonic"