summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Andrew Clemons2021-11-20 09:09:11 +0100
committer Willy Sudiarto Raharjo2021-11-22 03:10:14 +0100
commite6a25e142608ce1143c6f62156788d9a0a687335 (patch)
tree6241acad2cca719886e9292b7b0b590a14293a2c /python
parentdd26482806f52191eec723ad550ba4701f4b3d1c (diff)
downloadslackbuilds-e6a25e142608ce1143c6f62156788d9a0a687335.tar.gz
python/setuptools-scm: Removed (added to slackware.)
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/setuptools-scm/README5
-rw-r--r--python/setuptools-scm/setuptools-scm.SlackBuild79
-rw-r--r--python/setuptools-scm/setuptools-scm.info10
-rw-r--r--python/setuptools-scm/slack-desc19
4 files changed, 0 insertions, 113 deletions
diff --git a/python/setuptools-scm/README b/python/setuptools-scm/README
deleted file mode 100644
index a26279de6d..0000000000
--- a/python/setuptools-scm/README
+++ /dev/null
@@ -1,5 +0,0 @@
-setuptools_scm handles managing your python package versions in scm
-metadata instead of declaring them as the version argument or in a
-scm managed file.
-
-It also handles file finders for the supported scm's.
diff --git a/python/setuptools-scm/setuptools-scm.SlackBuild b/python/setuptools-scm/setuptools-scm.SlackBuild
deleted file mode 100644
index 678db71959..0000000000
--- a/python/setuptools-scm/setuptools-scm.SlackBuild
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for setuptools-scm
-
-# Copyright 2016-2019 Hunter Sezen California, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=setuptools-scm
-SRCNAM=$(printf %s $PRGNAM | tr - _)
-VERSION=${VERSION:-6.0.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/setuptools-scm/setuptools-scm.info b/python/setuptools-scm/setuptools-scm.info
deleted file mode 100644
index 66a0fff19e..0000000000
--- a/python/setuptools-scm/setuptools-scm.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="setuptools-scm"
-VERSION="6.0.1"
-HOMEPAGE="https://github.com/pypa/setuptools_scm"
-DOWNLOAD="https://files.pythonhosted.org/packages/57/38/930b1241372a9f266a7df2b184fb9d4f497c2cef2e016b014f82f541fe7c/setuptools_scm-6.0.1.tar.gz"
-MD5SUM="aa7f0efbbf46c5576db5994dd1ce3f8d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Hunter Sezen"
-EMAIL="orbea@riseup.net"
diff --git a/python/setuptools-scm/slack-desc b/python/setuptools-scm/slack-desc
deleted file mode 100644
index c4a33ef7de..0000000000
--- a/python/setuptools-scm/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-setuptools-scm: setuptools-scm (manage versions by scm tags)
-setuptools-scm:
-setuptools-scm: setuptools_scm handles managing your python package versions in scm
-setuptools-scm: metadata instead of declaring them as the version argument or in a
-setuptools-scm: scm managed file.
-setuptools-scm:
-setuptools-scm: It also handles file finders for the supported scms.
-setuptools-scm:
-setuptools-scm: Homepage: https://github.com/pypa/setuptools_scm
-setuptools-scm:
-setuptools-scm: