summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dave Woodfall2021-05-15 17:28:38 +0200
committer Willy Sudiarto Raharjo2021-05-19 13:40:15 +0200
commitf2bd24f4c1c0f2b02623302aec1d5dccf7308fe4 (patch)
tree7a6fbc03f2cd1cdf3c51cfcbff8ac284a3f64ffa /python
parent1359202a47f88b63d71fd1474549be7f0905a535 (diff)
downloadslackbuilds-f2bd24f4c1c0f2b02623302aec1d5dccf7308fe4.tar.gz
python/html5-parser: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/html5-parser/html5-parser.SlackBuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/html5-parser/html5-parser.SlackBuild b/python/html5-parser/html5-parser.SlackBuild
index 26af37b5f3..7ecc4d7fe4 100644
--- a/python/html5-parser/html5-parser.SlackBuild
+++ b/python/html5-parser/html5-parser.SlackBuild
@@ -55,7 +55,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true