summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dave Woodfall2021-05-21 22:32:09 +0200
committer Willy Sudiarto Raharjo2021-06-01 20:02:22 +0200
commitb2ce7dfab86e0812e9913bdd8961f0d1c1828995 (patch)
tree229417ed9c14d2b37d02c310bdaf175e1fe0e831 /python
parent25f2fb3c2060fa00595fbbd934c026074ad6193c (diff)
downloadslackbuilds-b2ce7dfab86e0812e9913bdd8961f0d1c1828995.tar.gz
python/WebHelpers: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/WebHelpers/README22
-rw-r--r--python/WebHelpers/WebHelpers.SlackBuild6
2 files changed, 13 insertions, 15 deletions
diff --git a/python/WebHelpers/README b/python/WebHelpers/README
index c78d8aa0c4..79cc2a8b40 100644
--- a/python/WebHelpers/README
+++ b/python/WebHelpers/README
@@ -1,16 +1,16 @@
-WebHelpers is a wide variety of utility functions for web applications and other
-applications.
+WebHelpers is a wide variety of utility functions for web applications
+and other applications.
It can be used with any web framework.
-WebHelpers includes the widely-used HTML tag builder with smart escaping and
-convenience functions for common tags such as form fields.
-The common builder ensures the tags are syntactically correct and prevent
-cross-site scripting attacks and double-escaping.
+WebHelpers includes the widely-used HTML tag builder with smart escaping
+and convenience functions for common tags such as form fields.
+The common builder ensures the tags are syntactically correct and
+prevent cross-site scripting attacks and double-escaping.
-Other helpers perform text processing, split a large number of records into
-pages, generate Atom/RSS feeds with geographical (GIS) data, handle MIME types,
-calculate numerica statistics, and more.
+Other helpers perform text processing, split a large number of records
+into pages, generate Atom/RSS feeds with geographical (GIS) data, handle
+MIME types, calculate numerica statistics, and more.
There are also high-level container types, including a value counter and
accumulator.
-There are lists of country names, country codes, US states, Canadian provinces,
-and UK counties.
+There are lists of country names, country codes, US states, Canadian
+provinces, and UK counties.
diff --git a/python/WebHelpers/WebHelpers.SlackBuild b/python/WebHelpers/WebHelpers.SlackBuild
index fd184a846e..b3bad83fad 100644
--- a/python/WebHelpers/WebHelpers.SlackBuild
+++ b/python/WebHelpers/WebHelpers.SlackBuild
@@ -53,10 +53,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README* MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION