summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dave Woodfall2021-05-14 22:34:37 +0200
committer Willy Sudiarto Raharjo2021-05-19 13:40:00 +0200
commit5e9e1e6a35fce481036a99d9ccc38c8fc74ca4a4 (patch)
treea1f65abc84b355c46b8142f385394438f4d99b3c /python
parent92b1a35a1ad9df88691bb5f835eb4870ab7fde8f (diff)
downloadslackbuilds-5e9e1e6a35fce481036a99d9ccc38c8fc74ca4a4.tar.gz
python/python-keyczar: Renamed python2-keyczar.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-keyczar/README5
-rw-r--r--python/python-keyczar/slack-desc19
-rw-r--r--python/python2-keyczar/README6
-rw-r--r--python/python2-keyczar/python2-keyczar.SlackBuild (renamed from python/python-keyczar/python-keyczar.SlackBuild)13
-rw-r--r--python/python2-keyczar/python2-keyczar.info (renamed from python/python-keyczar/python-keyczar.info)2
-rw-r--r--python/python2-keyczar/slack-desc19
6 files changed, 33 insertions, 31 deletions
diff --git a/python/python-keyczar/README b/python/python-keyczar/README
deleted file mode 100644
index 2c001c051c..0000000000
--- a/python/python-keyczar/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Keyczar is an open source cryptographic toolkit designed to make it easier and
-safer for developers to use cryptography in their applications. Keyczar supports
-authentication and encryption with both symmetric and asymmetric keys.
-
-Optional dependency: simplejson
diff --git a/python/python-keyczar/slack-desc b/python/python-keyczar/slack-desc
deleted file mode 100644
index 2a307452ce..0000000000
--- a/python/python-keyczar/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-keyczar: python-keyczar (cryptographic toolkit)
-python-keyczar:
-python-keyczar: Keyczar is an open source cryptographic toolkit designed to make it
-python-keyczar: easier and safer for developers to use cryptography in their
-python-keyczar: applications. Keyczar supports authentication and encryption with both
-python-keyczar: symmetric and asymmetric keys.
-python-keyczar:
-python-keyczar: Homepage: http://www.keyczar.org/
-python-keyczar:
-python-keyczar:
-python-keyczar:
diff --git a/python/python2-keyczar/README b/python/python2-keyczar/README
new file mode 100644
index 0000000000..6f3a57f5fe
--- /dev/null
+++ b/python/python2-keyczar/README
@@ -0,0 +1,6 @@
+Keyczar is an open source cryptographic toolkit designed to make it
+easier and safer for developers to use cryptography in their
+applications. Keyczar supports authentication and encryption with both
+symmetric and asymmetric keys.
+
+Optional dependency: simplejson
diff --git a/python/python-keyczar/python-keyczar.SlackBuild b/python/python2-keyczar/python2-keyczar.SlackBuild
index 7f5789989d..8a47a51173 100644
--- a/python/python-keyczar/python-keyczar.SlackBuild
+++ b/python/python2-keyczar/python2-keyczar.SlackBuild
@@ -22,14 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-keyczar
+PRGNAM=python2-keyczar
+SRCNAM=python-keyczar
VERSION=${VERSION:-0.716}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -45,9 +46,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -55,7 +56,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-keyczar/python-keyczar.info b/python/python2-keyczar/python2-keyczar.info
index 8858d0911c..f055b83d63 100644
--- a/python/python-keyczar/python-keyczar.info
+++ b/python/python2-keyczar/python2-keyczar.info
@@ -1,4 +1,4 @@
-PRGNAM="python-keyczar"
+PRGNAM="python2-keyczar"
VERSION="0.716"
HOMEPAGE="http://www.keyczar.org/"
DOWNLOAD="https://pypi.python.org/packages/c8/14/3ffb68671fef927fa5b60f21c43a04a4a007acbe939a26ba08b197fea6b3/python-keyczar-0.716.tar.gz"
diff --git a/python/python2-keyczar/slack-desc b/python/python2-keyczar/slack-desc
new file mode 100644
index 0000000000..7fc795c9c5
--- /dev/null
+++ b/python/python2-keyczar/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-keyczar: python2-keyczar (cryptographic toolkit)
+python2-keyczar:
+python2-keyczar: Keyczar is an open source cryptographic toolkit designed to make it
+python2-keyczar: easier and safer for developers to use cryptography in their
+python2-keyczar: applications. Keyczar supports authentication and encryption with both
+python2-keyczar: symmetric and asymmetric keys.
+python2-keyczar:
+python2-keyczar: Homepage: http://www.keyczar.org/
+python2-keyczar:
+python2-keyczar:
+python2-keyczar: