summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2019-12-25 18:26:10 +0100
committer Willy Sudiarto Raharjo2019-12-31 12:06:26 +0100
commitd1277ad9b4919561032e3dbe17cdf038fee3cda7 (patch)
tree506756f0e9e3ee3a4ef8ed3ca67ba298d422a63d /python
parent6c307a933c404d8149da4a4170c12cb7753dd368 (diff)
downloadslackbuilds-d1277ad9b4919561032e3dbe17cdf038fee3cda7.tar.gz
python/requests-oauthlib: Updated for version 1.3.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/requests-oauthlib/requests-oauthlib.SlackBuild9
-rw-r--r--python/requests-oauthlib/requests-oauthlib.info6
2 files changed, 10 insertions, 5 deletions
diff --git a/python/requests-oauthlib/requests-oauthlib.SlackBuild b/python/requests-oauthlib/requests-oauthlib.SlackBuild
index cd03b81261..f915b00dba 100644
--- a/python/requests-oauthlib/requests-oauthlib.SlackBuild
+++ b/python/requests-oauthlib/requests-oauthlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for requests-oauthlib
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=requests-oauthlib
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+#python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/requests-oauthlib/requests-oauthlib.info b/python/requests-oauthlib/requests-oauthlib.info
index f67793acfa..4f8e3a9995 100644
--- a/python/requests-oauthlib/requests-oauthlib.info
+++ b/python/requests-oauthlib/requests-oauthlib.info
@@ -1,8 +1,8 @@
PRGNAM="requests-oauthlib"
-VERSION="1.0.0"
+VERSION="1.3.0"
HOMEPAGE="https://github.com/requests/requests-oauthlib"
-DOWNLOAD="https://files.pythonhosted.org/packages/95/be/072464f05b70e4142cb37151e215a2037b08b1400f8a56f2538b76ca6205/requests-oauthlib-1.0.0.tar.gz"
-MD5SUM="e867404084b688dbfb879b9ac9ac040a"
+DOWNLOAD="https://files.pythonhosted.org/packages/23/eb/68fc8fa86e0f5789832f275c8289257d8dc44dbe93fce7ff819112b9df8f/requests-oauthlib-1.3.0.tar.gz"
+MD5SUM="1ebcd55f1b1b9281940b4bc33010e2ba"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python-requests python-oauthlib"