summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2020-01-18 01:47:59 +0100
committer Willy Sudiarto Raharjo2020-01-18 01:47:59 +0100
commita7ac25a4b1424457802304a26696d29d7b6439e9 (patch)
tree96f8aa285ca466dec2bae0a50a8e459c46568868 /python
parent9c6a37b786aed8b6f92b83c69db066a9e0b17fa2 (diff)
downloadslackbuilds-a7ac25a4b1424457802304a26696d29d7b6439e9.tar.gz
python/python-parsedatetime: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-parsedatetime/python-parsedatetime.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/python-parsedatetime/python-parsedatetime.SlackBuild b/python/python-parsedatetime/python-parsedatetime.SlackBuild
index 3fce04f6bb..281f6eacc3 100644
--- a/python/python-parsedatetime/python-parsedatetime.SlackBuild
+++ b/python/python-parsedatetime/python-parsedatetime.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-parsedatetime
-# Copyright 2015-2017 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015-2020 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=python-parsedatetime
DIRNAM=parsedatetime
VERSION=${VERSION:-2.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true