summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2019-12-25 18:22:14 +0100
committer Willy Sudiarto Raharjo2019-12-31 12:06:26 +0100
commit6c307a933c404d8149da4a4170c12cb7753dd368 (patch)
tree8bce7f775e34e5f2ea83daed71bd051943ecef24 /python
parent23394e3bf89bee106759f25db3da9013ad384a6c (diff)
downloadslackbuilds-6c307a933c404d8149da4a4170c12cb7753dd368.tar.gz
python/python-oauthlib: Updated for version 3.1.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/python-oauthlib/python-oauthlib.SlackBuild9
-rw-r--r--python/python-oauthlib/python-oauthlib.info6
2 files changed, 10 insertions, 5 deletions
diff --git a/python/python-oauthlib/python-oauthlib.SlackBuild b/python/python-oauthlib/python-oauthlib.SlackBuild
index 83419d7165..469532ccda 100644
--- a/python/python-oauthlib/python-oauthlib.SlackBuild
+++ b/python/python-oauthlib/python-oauthlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-oauthlib
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-oauthlib
SRCNAM=$(echo $PRGNAM | cut -c8-15)
-VERSION=${VERSION:-2.1.0}
+VERSION=${VERSION:-3.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-oauthlib/python-oauthlib.info b/python/python-oauthlib/python-oauthlib.info
index b48e9115ea..5924600ce1 100644
--- a/python/python-oauthlib/python-oauthlib.info
+++ b/python/python-oauthlib/python-oauthlib.info
@@ -1,8 +1,8 @@
PRGNAM="python-oauthlib"
-VERSION="2.1.0"
+VERSION="3.1.0"
HOMEPAGE="https://github.com/idan/oauthlib"
-DOWNLOAD="https://files.pythonhosted.org/packages/df/5f/3f4aae7b28db87ddef18afed3b71921e531ca288dc604eb981e9ec9f8853/oauthlib-2.1.0.tar.gz"
-MD5SUM="544b15398afe48d9493fa60d571bd8c7"
+DOWNLOAD="https://files.pythonhosted.org/packages/fc/c7/829c73c64d3749da7811c06319458e47f3461944da9d98bb4df1cb1598c2/oauthlib-3.1.0.tar.gz"
+MD5SUM="43cb2b5bac983712ee55076b61181cc2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""