summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Fernando Lopez Jr2019-10-13 04:29:51 +0200
committer Willy Sudiarto Raharjo2019-10-13 04:29:51 +0200
commitb8eca4b2e54c76def9eaa6aa1ed7fc2ee1d3d5ac (patch)
tree9fe6f9a4989e82c092142e74ae871bc00fd50c60 /python
parent617f80132e197510a87e7699312c039ba6008116 (diff)
downloadslackbuilds-b8eca4b2e54c76def9eaa6aa1ed7fc2ee1d3d5ac.tar.gz
python/zeep: Added (Python SOAP client).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/zeep/README12
-rw-r--r--python/zeep/slack-desc19
-rw-r--r--python/zeep/zeep.SlackBuild72
-rw-r--r--python/zeep/zeep.info10
4 files changed, 113 insertions, 0 deletions
diff --git a/python/zeep/README b/python/zeep/README
new file mode 100644
index 0000000000..83cccd6b88
--- /dev/null
+++ b/python/zeep/README
@@ -0,0 +1,12 @@
+A fast and modern Python SOAP client
+
+Highlights:
+
+Compatible with Python 2.7, 3.3, 3.4, 3.5, 3.6, 3.7 and PyPy
+Build on top of lxml and requests
+- Support for Soap 1.1, Soap 1.2 and HTTP bindings
+- Support for WS-Addressing headers
+- Support for WSSE (UserNameToken / x.509 signing)
+- Support for tornado async transport via gen.coroutine (Python 2.7+)
+- Support for asyncio via aiohttp (Python 3.5+)
+- Experimental support for XOP messages \ No newline at end of file
diff --git a/python/zeep/slack-desc b/python/zeep/slack-desc
new file mode 100644
index 0000000000..26bf8fef92
--- /dev/null
+++ b/python/zeep/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+zeep: zeep (Python SOAP client)
+zeep:
+zeep: A fast and modern Python SOAP client.
+zeep:
+zeep:
+zeep:
+zeep:
+zeep:
+zeep:
+zeep:
+zeep:
diff --git a/python/zeep/zeep.SlackBuild b/python/zeep/zeep.SlackBuild
new file mode 100644
index 0000000000..0c88544f7b
--- /dev/null
+++ b/python/zeep/zeep.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for zeep
+
+# Copyright 2019 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=zeep
+VERSION=${VERSION:-3.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES CONTRIBUTORS.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/zeep/zeep.info b/python/zeep/zeep.info
new file mode 100644
index 0000000000..20a245eb90
--- /dev/null
+++ b/python/zeep/zeep.info
@@ -0,0 +1,10 @@
+PRGNAM="zeep"
+VERSION="3.4.0"
+HOMEPAGE="https://pypi.org/project/zeep/"
+DOWNLOAD="https://files.pythonhosted.org/packages/0c/3c/cef1b4b66e8fc221daca7fe7eaca0048820866ee9c1ee6522afc9b924af1/zeep-3.4.0.tar.gz"
+MD5SUM="70f1b5bc7c35173a69bfea4f5ffa77e7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"