summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Yth - Arnaud2019-10-23 18:51:44 +0200
committer Willy Sudiarto Raharjo2019-10-23 18:51:44 +0200
commit7871994eef09712c80bbf7a0172b201848d2da2d (patch)
tree4f5fb119e1e506c14ec0ed29ba2637c3b07d036d /python
parent1031bd382b1850a22df08a113a9149fc558db275 (diff)
downloadslackbuilds-7871994eef09712c80bbf7a0172b201848d2da2d.tar.gz
python/Paste: Added (Middleware).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/Paste/Paste.SlackBuild69
-rw-r--r--python/Paste/Paste.info10
-rw-r--r--python/Paste/README9
-rw-r--r--python/Paste/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/python/Paste/Paste.SlackBuild b/python/Paste/Paste.SlackBuild
new file mode 100644
index 0000000000..2009622602
--- /dev/null
+++ b/python/Paste/Paste.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# SlackBuild script for Paste.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Paste
+VERSION=${VERSION:-3.2.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/Paste/Paste.info b/python/Paste/Paste.info
new file mode 100644
index 0000000000..a343d90386
--- /dev/null
+++ b/python/Paste/Paste.info
@@ -0,0 +1,10 @@
+PRGNAM="Paste"
+VERSION="3.2.2"
+HOMEPAGE="https://pythonpaste.readthedocs.io/"
+DOWNLOAD="https://pypi.python.org/packages/source/P/Paste/Paste-3.2.2.tar.gz"
+MD5SUM="788fceb192bc338f1a3e2a8f78fd42b6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/Paste/README b/python/Paste/README
new file mode 100644
index 0000000000..895b98c38a
--- /dev/null
+++ b/python/Paste/README
@@ -0,0 +1,9 @@
+Paste provides several pieces of "middleware" (or filters) that can be nested to
+build web applications.
+Each piece of middleware uses the WSGI (PEP 333) interface, and should be
+compatible with other middleware based on those interfaces.
+
+
+Paste is in maintenance mode and recently moved from bitbucket to github.
+Patches are accepted to keep it on life support, but for the most part,
+please consider using other options.
diff --git a/python/Paste/slack-desc b/python/Paste/slack-desc
new file mode 100644
index 0000000000..81132d6439
--- /dev/null
+++ b/python/Paste/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Paste: Paste (Middleware)
+Paste:
+Paste: Paste provides several pieces of "middleware" (or filters) that can
+Paste: be nested to build web applications.
+Paste:
+Paste: Each piece of middleware uses the WSGI (PEP 333) interface, and
+Paste: should be compatible with other middleware based on those interfaces.
+Paste:
+Paste:
+Paste:
+Paste: