summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Yth - Arnaud2019-10-25 10:08:11 +0200
committer Willy Sudiarto Raharjo2019-10-25 10:08:11 +0200
commit598d34301d70eda1cbef99614c23e75b03b71591 (patch)
tree6d2881cec21952a6ade13c40c15d0273ee058bda /python
parent415d49b7c5ffd8afa2361af5f514b994beb36245 (diff)
downloadslackbuilds-598d34301d70eda1cbef99614c23e75b03b71591.tar.gz
python/TurboGears2: Added (Web Framework).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/TurboGears2/README6
-rw-r--r--python/TurboGears2/TurboGears2.SlackBuild69
-rw-r--r--python/TurboGears2/TurboGears2.info10
-rw-r--r--python/TurboGears2/slack-desc19
4 files changed, 104 insertions, 0 deletions
diff --git a/python/TurboGears2/README b/python/TurboGears2/README
new file mode 100644
index 0000000000..174c68922a
--- /dev/null
+++ b/python/TurboGears2/README
@@ -0,0 +1,6 @@
+The Web Framework that scales with you.
+
+TurboGears 2 is built on top of the experience of several next generation web
+frameworks including TurboGears 1 (of course), Django, and Rails.
+All of these frameworks had limitations that frustrated us, and TG2 was built
+as an answer to that frustration.
diff --git a/python/TurboGears2/TurboGears2.SlackBuild b/python/TurboGears2/TurboGears2.SlackBuild
new file mode 100644
index 0000000000..873f19ef9b
--- /dev/null
+++ b/python/TurboGears2/TurboGears2.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# SlackBuild script for TurboGears2.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=TurboGears2
+VERSION=${VERSION:-2.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/TurboGears2/TurboGears2.info b/python/TurboGears2/TurboGears2.info
new file mode 100644
index 0000000000..92278a2ef5
--- /dev/null
+++ b/python/TurboGears2/TurboGears2.info
@@ -0,0 +1,10 @@
+PRGNAM="TurboGears2"
+VERSION="2.4.2"
+HOMEPAGE="http://www.turbogears.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/T/TurboGears2/TurboGears2-2.4.2.tar.gz"
+MD5SUM="075037acfe8871385187ec64e850f90e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="crank"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/TurboGears2/slack-desc b/python/TurboGears2/slack-desc
new file mode 100644
index 0000000000..2433366ea3
--- /dev/null
+++ b/python/TurboGears2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+TurboGears2: TurboGears (Web Framework)
+TurboGears2:
+TurboGears2: TurboGears 2 is built on top of the experience of several next
+TurboGears2: generation web frameworks including TurboGears 1 (of course), Django,
+TurboGears2: and Rails.
+TurboGears2:
+TurboGears2: All of these frameworks had limitations that frustrated us, and TG2
+TurboGears2: was built as an answer to that frustration.
+TurboGears2:
+TurboGears2:
+TurboGears2: