summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Vijay Marcel2022-09-12 19:07:11 +0200
committer bedlam2022-09-12 19:07:11 +0200
commit6b979746c45761e6138e9c4dd3654c4016983efa (patch)
tree55803b4a71b2a2b656b698263cf0657afad2c7a3 /python
parent72dca8d92076046dcd8b7dda60e8690bfe434bdc (diff)
downloadslackbuilds-6b979746c45761e6138e9c4dd3654c4016983efa.tar.gz
python/memory-profiler: Added (Python Memory Profiler)
Signed-off-by: bedlam <dave@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/memory-profiler/README6
-rw-r--r--python/memory-profiler/memory-profiler.SlackBuild97
-rw-r--r--python/memory-profiler/memory-profiler.info10
-rw-r--r--python/memory-profiler/slack-desc19
4 files changed, 132 insertions, 0 deletions
diff --git a/python/memory-profiler/README b/python/memory-profiler/README
new file mode 100644
index 0000000000..0081a416bd
--- /dev/null
+++ b/python/memory-profiler/README
@@ -0,0 +1,6 @@
+This is a python module for monitoring memory
+consumption of a process as well as line-by-line analysis
+of memory consumption for python programs.
+
+matplotlib is an optional dependency it is used
+for plotting memory consumption generated by mprof run
diff --git a/python/memory-profiler/memory-profiler.SlackBuild b/python/memory-profiler/memory-profiler.SlackBuild
new file mode 100644
index 0000000000..ac22aeea45
--- /dev/null
+++ b/python/memory-profiler/memory-profiler.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/bash
+
+# Slackware build script for memory-profiler
+
+# Copyright 2022 Vijay Marcel
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=memory-profiler
+VERSION=${VERSION:-0.60.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+trap 'echo "$0 FAILED at line $LINENO!" | tee -a $OUTPUT/error-${PRGNAM}.log' ERR
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf memory_profiler-$VERSION
+tar xvf $CWD/memory_profiler-$VERSION.tar.gz
+cd memory_profiler-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py build
+python3 setup.py install --root=$PKG --optimize=1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/memory-profiler/memory-profiler.info b/python/memory-profiler/memory-profiler.info
new file mode 100644
index 0000000000..c603fa092f
--- /dev/null
+++ b/python/memory-profiler/memory-profiler.info
@@ -0,0 +1,10 @@
+PRGNAM="memory-profiler"
+VERSION="0.60.0"
+HOMEPAGE="https://github.com/pythonprofilers/memory_profiler"
+DOWNLOAD="https://pypi.io/packages/source/m/memory_profiler/memory_profiler-0.60.0.tar.gz"
+MD5SUM="c4d29b47885c32581f5bcefb44d2ca8e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="psutil"
+MAINTAINER="Vijay Marcel"
+EMAIL="vijaymarcel@outlook.com"
diff --git a/python/memory-profiler/slack-desc b/python/memory-profiler/slack-desc
new file mode 100644
index 0000000000..3971a7f7f5
--- /dev/null
+++ b/python/memory-profiler/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+memory-profiler: memory-profiler (Python Memory Profiler)
+memory-profiler:
+memory-profiler: This is a python module for monitoring memory
+memory-profiler: consumption of a process as well as line-by-line analysis
+memory-profiler: of memory consumption for python programs.
+memory-profiler:
+memory-profiler: Homepage:https://github.com/pythonprofilers/memory_profiler
+memory-profiler:
+memory-profiler:
+memory-profiler:
+memory-profiler: