summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Arn02022-03-14 11:21:56 +0100
committer Willy Sudiarto Raharjo2022-03-17 18:26:02 +0100
commit14db2091270b4e2d8a5b68c14ba09377331d476f (patch)
tree17a9b59db5e21914fa35b7ad6562134c8507672c /python
parent342ab98662950a9029950869ce8be0917b9a52d4 (diff)
downloadslackbuilds-14db2091270b4e2d8a5b68c14ba09377331d476f.tar.gz
python/python2-attrs: renamed from attrs, updated for version 21.2.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/attrs/attrs.info10
-rw-r--r--python/attrs/slack-desc19
-rw-r--r--python/python2-attrs/README (renamed from python/attrs/README)0
-rw-r--r--python/python2-attrs/python2-attrs.SlackBuild (renamed from python/attrs/attrs.SlackBuild)15
-rw-r--r--python/python2-attrs/python2-attrs.info10
-rw-r--r--python/python2-attrs/slack-desc19
6 files changed, 37 insertions, 36 deletions
diff --git a/python/attrs/attrs.info b/python/attrs/attrs.info
deleted file mode 100644
index 06eb1343a8..0000000000
--- a/python/attrs/attrs.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="attrs"
-VERSION="18.2.0"
-HOMEPAGE="https://pypi.python.org/pypi/attrs"
-DOWNLOAD="https://files.pythonhosted.org/packages/0f/9e/26b1d194aab960063b266170e53c39f73ea0d0d3f5ce23313e0ec8ee9bdf/attrs-18.2.0.tar.gz"
-MD5SUM="44700294787c8018858777fc150e5d40"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/attrs/slack-desc b/python/attrs/slack-desc
deleted file mode 100644
index c712e5ea33..0000000000
--- a/python/attrs/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-attrs: attrs (attributes without boilerplate)
-attrs:
-attrs: attrs is an MIT-licensed Python package with class decorators that
-attrs: ease the chores of implementing the most common attribute-related
-attrs: object protocols.
-attrs:
-attrs: Homepage: https://pypi.python.org/pypi/attrs
-attrs:
-attrs:
-attrs:
-attrs:
diff --git a/python/attrs/README b/python/python2-attrs/README
index 8f3e9d786e..8f3e9d786e 100644
--- a/python/attrs/README
+++ b/python/python2-attrs/README
diff --git a/python/attrs/attrs.SlackBuild b/python/python2-attrs/python2-attrs.SlackBuild
index c589d81f45..2ccc3c88c3 100644
--- a/python/attrs/attrs.SlackBuild
+++ b/python/python2-attrs/python2-attrs.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Slackware build script for attrs
+# Slackware build script for python2-attrs
# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
# Copyright 2016-2018 Markus Reichelt, Aachen, DE
@@ -25,8 +25,9 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=attrs
-VERSION=${VERSION:-18.2.0}
+PRGNAM=python2-attrs
+SRCNAM=${PRGNAM#python2-*}
+VERSION=${VERSION:-21.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -70,9 +71,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,7 +81,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python2-attrs/python2-attrs.info b/python/python2-attrs/python2-attrs.info
new file mode 100644
index 0000000000..e213b8b6ce
--- /dev/null
+++ b/python/python2-attrs/python2-attrs.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-attrs"
+VERSION="21.2.0"
+HOMEPAGE="https://pypi.python.org/pypi/attrs"
+DOWNLOAD="https://pypi.python.org/packages/source/a/attrs/attrs-21.2.0.tar.gz"
+MD5SUM="06af884070d9180694becdb106e5cd65"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python2-attrs/slack-desc b/python/python2-attrs/slack-desc
new file mode 100644
index 0000000000..2fd9f15a42
--- /dev/null
+++ b/python/python2-attrs/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-attrs: python2-attrs (attributes without boilerplate)
+python2-attrs:
+python2-attrs: attrs is an MIT-licensed Python package with class decorators that
+python2-attrs: ease the chores of implementing the most common attribute-related
+python2-attrs: object protocols.
+python2-attrs:
+python2-attrs: Homepage: https://pypi.python.org/pypi/attrs
+python2-attrs:
+python2-attrs:
+python2-attrs:
+python2-attrs: