summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Arn02022-03-14 13:47:52 +0100
committer Willy Sudiarto Raharjo2022-03-17 18:26:02 +0100
commit0d244f3f8d56f5fc3507629c185ace92dce33a94 (patch)
tree5d3c5b8e9ebb6993cb3621d7461cfb32d42d3e38 /python
parent1997dc5374ed17e7b195dfd840a8a151cf54eb12 (diff)
downloadslackbuilds-0d244f3f8d56f5fc3507629c185ace92dce33a94.tar.gz
python/anyjson: Removed, very old and not in any more REQUIRES
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/anyjson/README6
-rw-r--r--python/anyjson/anyjson-python3.patch.gzbin896 -> 0 bytes
-rw-r--r--python/anyjson/anyjson.SlackBuild79
-rw-r--r--python/anyjson/anyjson.info10
-rw-r--r--python/anyjson/slack-desc19
5 files changed, 0 insertions, 114 deletions
diff --git a/python/anyjson/README b/python/anyjson/README
deleted file mode 100644
index 6a6a285035..0000000000
--- a/python/anyjson/README
+++ /dev/null
@@ -1,6 +0,0 @@
-Convenience module to import the best available json serialize/deserializer installed
-
-Anyjson loads whichever is the fastest JSON module installed and provides a uniform
-API regardless of which JSON implementation is used.
-
-Originally part of carrot
diff --git a/python/anyjson/anyjson-python3.patch.gz b/python/anyjson/anyjson-python3.patch.gz
deleted file mode 100644
index 59e04e0e1d..0000000000
--- a/python/anyjson/anyjson-python3.patch.gz
+++ /dev/null
Binary files differ
diff --git a/python/anyjson/anyjson.SlackBuild b/python/anyjson/anyjson.SlackBuild
deleted file mode 100644
index a7bbe56f33..0000000000
--- a/python/anyjson/anyjson.SlackBuild
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/bash
-
-# SlackBuild script for anyjson.
-# Yth | Pont-en-Royans, France | yth@ythogtha.org
-
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=anyjson
-VERSION=${VERSION:-0.3.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-zcat $CWD/anyjson-python3.patch.gz | patch -p1
-sed -i 's/use_2to3=True/use_2to3=False/g' setup.py
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/anyjson/anyjson.info b/python/anyjson/anyjson.info
deleted file mode 100644
index 0d2d737cff..0000000000
--- a/python/anyjson/anyjson.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="anyjson"
-VERSION="0.3.3"
-HOMEPAGE="https://pypi.org/project/anyjson/"
-DOWNLOAD="https://pypi.python.org/packages/source/a/anyjson/anyjson-0.3.3.tar.gz"
-MD5SUM="2ea28d6ec311aeeebaf993cb3008b27c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/anyjson/slack-desc b/python/anyjson/slack-desc
deleted file mode 100644
index 9a9c8ef35c..0000000000
--- a/python/anyjson/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-anyjson: anyjson (Python Module)
-anyjson:
-anyjson: Convenience module to import the best available json
-anyjson: serialize/deserializer installed
-anyjson:
-anyjson:
-anyjson:
-anyjson:
-anyjson:
-anyjson:
-anyjson: