summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author B. Watson2021-12-05 18:00:20 +0100
committer Willy Sudiarto Raharjo2021-12-10 02:37:35 +0100
commit6995c9a37954704cfac839bda305ef72f70592a4 (patch)
tree25b111884eb8c9b0c767c00b911936b38964308a /python
parent199a463086fa4cf7764e40f8c45657fe09c21bc0 (diff)
downloadslackbuilds-6995c9a37954704cfac839bda305ef72f70592a4.tar.gz
python-djvulibre: Rename to python-djvulibre, support py3.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-djvulibre/README (renamed from python/python2-djvulibre/README)2
-rw-r--r--python/python-djvulibre/slack-desc19
-rw-r--r--python/python2-djvulibre/python2-djvulibre.SlackBuild73
-rw-r--r--python/python2-djvulibre/python2-djvulibre.info10
-rw-r--r--python/python2-djvulibre/slack-desc19
5 files changed, 21 insertions, 102 deletions
diff --git a/python/python2-djvulibre/README b/python/python-djvulibre/README
index 7b10cf0e56..62de2db972 100644
--- a/python/python2-djvulibre/README
+++ b/python/python-djvulibre/README
@@ -2,3 +2,5 @@ python-djvulibre (python bindings for djvulibre)
python-djvulibre is a set of Python bindings for the DjVuLibre library,
an open source implementation of DjVu.
+
+Bindings for both Python 2 and Python 3 are included.
diff --git a/python/python-djvulibre/slack-desc b/python/python-djvulibre/slack-desc
new file mode 100644
index 0000000000..ea2fc0662e
--- /dev/null
+++ b/python/python-djvulibre/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-djvulibre: python-djvulibre (python bindings for djvulibre)
+python-djvulibre:
+python-djvulibre: python-djvulibre is a set of Python bindings for the DjVuLibre
+python-djvulibre: library, an open source implementation of DjVu.
+python-djvulibre:
+python-djvulibre:
+python-djvulibre:
+python-djvulibre:
+python-djvulibre:
+python-djvulibre:
+python-djvulibre:
diff --git a/python/python2-djvulibre/python2-djvulibre.SlackBuild b/python/python2-djvulibre/python2-djvulibre.SlackBuild
deleted file mode 100644
index fc8d8e8f56..0000000000
--- a/python/python2-djvulibre/python2-djvulibre.SlackBuild
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-djvulibre
-
-# Written by B. Watson (yalhcru@gmail.com)
-
-# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python2-djvulibre
-SRCNAM=python-djvulibre
-VERSION=${VERSION:-0.8.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-# Not bothering with SLKCFLAGS and LIBDIRSUFFIX as there's no obvious
-# way to pass them to setup.py, and also because -O3 -fPIC is already
-# the default (I assume upstream tests with -O3 so no reason to
-# force -O2). Most SBo python SlackBuilds seem to set SLKCFLAGS and
-# LIBDIRSUFFIX, then never use them, so the template might need to
-# be updated...
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a doc/* examples $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-djvulibre/python2-djvulibre.info b/python/python2-djvulibre/python2-djvulibre.info
deleted file mode 100644
index 6419a3eb88..0000000000
--- a/python/python2-djvulibre/python2-djvulibre.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python2-djvulibre"
-VERSION="0.8.5"
-HOMEPAGE="http://jwilk.net/software/python-djvulibre"
-DOWNLOAD="https://github.com/jwilk/python-djvulibre/archive/0.8.5/python-djvulibre-0.8.5.tar.gz"
-MD5SUM="98cbb3ecb34e9df1cb0514a259e580cf"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
diff --git a/python/python2-djvulibre/slack-desc b/python/python2-djvulibre/slack-desc
deleted file mode 100644
index 94ce2f3b79..0000000000
--- a/python/python2-djvulibre/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python2-djvulibre: python2-djvulibre (python bindings for djvulibre)
-python2-djvulibre:
-python2-djvulibre: python2-djvulibre is a set of Python bindings for the DjVuLibre
-python2-djvulibre: library, an open source implementation of DjVu.
-python2-djvulibre:
-python2-djvulibre:
-python2-djvulibre:
-python2-djvulibre:
-python2-djvulibre:
-python2-djvulibre:
-python2-djvulibre: